Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1 (Edited)
Hello Gentelman. After a WOT exercise last month, my 1993 Cadillac Eldorado ETC began acting up. It is to the point now where it is un-drivable. It starts fine but idles rough, and then under acceleration it is very sluggish with no power. It smokes thru the exhaust a great deal to the point of other drivers and pedestrians complaining. The ABS light stays on, the Service Engine Soon light stays on and the Traction Disabled message stays on. After paying $300 to the local dealer, they said they couldn’t find the problem. My question is: with all of the warning lights and messages appearing at once, and something obviously wrong with the engine fuel system, could I be having a problem with the main computer that regulates all of this? Does that ever happen? If so, can I re-program or re-set the computer? Thanks
 

·
Registered
2008 SRX
Joined
·
403 Posts
As usual, start by pulling codes. Do a search on this if you're not familiar. If you payed the dealer $300, they must have had an answer of some sort. I think charging a customer 1hr diag is harsh in most cases if your car was not diagnosed. They charged you $300 and had no diagnosis???
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
The dealer did put in three plugs and write a diagnosis, but the problem wasn't fixed and he didn't give me a copy of the diagnosis. It may be in the records that they keep, but I wasn't given a copy. I do remember him saying that they had checked the codes and had found nothing relating to the problems, so I didn't feel the need to check them myself. Guess I'll do that tomorrow. Can you tell me if the computer that holds all of these codes is the same one that manages the engine system? Thanks
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Here are the error codes that popped up just a few minutes ago: PO30 ISC RPM out of range, P137 Loss of TCS (traction control system) data, IO32 Loss of ABS/TCS data, TO72 Serial data link fault, SO44 Lift or dive signal fault and SO60 Left front position sensor fault. With the exception of the PO30, it amounts to the loss of data and some signal faults. Any thoughts on the relationship of these codes to the performance problems I'm having? Thanks
 
1 - 4 of 4 Posts
Top