Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
93 devil hard start

Hello All,Iam new to this forum and I have a starting problem .The engine turns over for a long time before it starts and I get a E70,and a E53 code.does anyone have a clue to the problem.thanx
 

·
Registered
Joined
·
7,658 Posts
Re: 93 devil hard start

Fuel pump, fuel filter, or fuel pressure regulator.... Or possibly one or more of those...... Dont know what those codes mean..

How does the car run when its actually running....? Normal??
 

·
Registered
Joined
·
11,009 Posts
IIRC "E" and "P" are the same, in that case:

P053 .......... Distributor Signal Interrupt

P070 .......... Intermittent TPS Signal

and they both seem like they could be a cause to your problem... I would recomemnd getting a factory service manual on ebay (mine was under $50 shipped) for your car.... has all the info you need, explains this, and how to fix/test it all..... I would also clear all the codes, drive around for awhile and see if they come back....

.... a couple of months ago I was getting the E070 also, I was like wtf? and another code (caused by me though) so I reset the system, and have been driving around since and it hasn't came back, so it must have been a fluky thing...besides the rough at times 4.9 idel thing, the engine is amazing.....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanx for the reply,The engine run great after the hard start.I replaced the t.p.s. and the coolant temp sensor but it still takes a lot of cranking.If the engine is warm it starts better.and now it helps if i press on the peddle just a little.thanx,
 

·
Registered
Joined
·
581 Posts
I experienced the same thing while I had a 83 Eldorado.

It turned out that the relay to turn on the fuel pump for
a couple of seconds when the ignition is on was bad.
So, when the ignition was turned on, the fuel pump didn't
get started, unless I cranked the engine to build up the
oil pressure to turn on the fuel pump via the oil pressure
sensor.

I am not sure if this is your case.
Good luck!
 

·
Registered
Joined
·
581 Posts
Forgot to say more.

Try to listen the subtle sound of fuel pump from the tank
when you turn on the ignition. You should be able to hear
it for a couple of seconds.

Or you can turn on (but don't start the engine) the car
and check the fuel relieve valve. Fuel should shoot out
for a moment. If you have a fuel gauge, it is safer to
use it to check...
 

·
Registered
Joined
·
7,658 Posts
Has the fuel filter been replaced recently...... Its gonna be a good idea to replace it anyway!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Thanks for all the replys,the devile is a little better on starting than it was before i replaced the t.p.s.sensor - the coolant sensor - air temp sensor.after i ran the learn procedure iget a sss on the lower left side of the dash ,can someone tell me what it means .thanks
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
5 Participants
fender bender
Top