Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
93 Coupe Deville
Joined
·
8 Posts
Discussion Starter #1
1993 Coupe Deville, 168k well maintained miles, car is in excellent shapre but the other day after leaving the car in the Florida sun all day I started it up and noticed the fuel cluser and A/C climate control display were dark. Intermittently came back but then went dead for good. I replaced the BCM and after reconnecting the battery ground cable, started the car and they started working for about 10 seconds then went out again not to return.

I though maybe something in the steering column or maybe the ignition switch but jiggling the switch does not pring back even a flicker. I know the computers work in series, is there any connection between the Climate Control Head module and the Fuel Gauge cluster? Expensive to replace the A/C Control Head, anything else I can look at? Checked all fuses but noticed a few relays under the dash were spliced when an aftermarket alarm and keyless entry module was added years ago before my ownership. I am the second owner.

Any suggestions would be greatly appreciated, I love this car and would hate to side line it for lack of A/C and Fuel Gauge...!

Thanks....feel free to answer back via email at [email protected]

Alan-
1993 Coupe Deville Black on Black Beauty
 

·
Registered
2008 SRX
Joined
·
403 Posts
Pull them out one at a time, then switch places ( they should plug into the opposite connector), then unplug one at a time. Do either light up, do you get any results. Probably one panel or the other is dragging the line down - they are directly related.
 

·
Registered
93 Coupe Deville
Joined
·
8 Posts
Discussion Starter #3
I have pulled every fuse and relay, swapped them, moved them around tested them....I agree, something is pulling down the circuit but without an acurate wiring diagram and schematic I think I am going to be screwed. If there any other suggestions out there please feel free to chime in..!

Alan-

[email protected]
 

·
Registered
93 Coupe Deville
Joined
·
8 Posts
Discussion Starter #4
I think I found the problem but I do not have a NEXT STEP...

Found that the fuse for the A/C Programmer located behind the glove box (passenger side) is not getting voltage. The fuse is good (obvious check) and I then checked all other fuses related to the A/C Programmer (black plastic housing with circuit board and solenoids for air control of dampers next to the pasenger side fuse box) which checked out OK. This leads me to beleive that wherever the A/C Programmer fuse position gets voltage from is the source of the problem. Without a schematic or wiring diagram I am done..!

Anyone with a schematic or wiring diagram that can help out there?

Thanks,

Alan-

[email protected]
 

·
Registered
2008 SRX
Joined
·
403 Posts
A 16V circuit (ORN/BLK wire) supplied by the BCM powers up the VF displays. Check for 16V at that circuit on terminal D13 of the BCM, terminal P of the FDC and the CCP, and terminal 5 at radio connector C4. The connectors of the FDC and CCP are identical. Did you try removing the FDC and CCP one at a time? Are the radio, IPC displays working while the other 2 are out?
 

·
Registered
'87 SDV
Joined
·
1,296 Posts
cadillac_tech has you on the right track. If the programmer circuit was faulty, you would be getting a 'c' display. If the displays are dead, it's most likely a fault in the 16V VF display circuit. All VF displays in the C-body are series wired like Christmas tree lights, and any break in that circuit affects everything down the line. In your car, the series is Radio>CCP>FDC (then digital dash if you have one). Keep in mind the display power and the data are fed on separate circuits.

If someone has been cutting wires under the dash, that's the best place to start - track that Orange/Black wire.
 

·
Registered
93 Coupe Deville
Joined
·
8 Posts
Discussion Starter #7
Thanks guys, I will be giving that voltage check a try this afternoon if the temperature is a little cooler, Black on Black with no air flow and I sweat up a storm down here in FL. I will report back to this Thread what I find.

Thanks again.

Alan-
 
1 - 7 of 7 Posts
Top