Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,
New to the forum and new proud owner. My 90 year old aunt gave me her 92 Eldorado, it's in perfect condition, 40K miles. Only problem I've found is the horn doesn't work. I switched out the horn and that isn't the problem....also, the fuse is good. Any suggestions? Is there a relay? Where? How do I test?
 

·
Registered
Joined
·
520 Posts
MartyK said:
Hi,
New to the forum and new proud owner. My 90 year old aunt gave me her 92 Eldorado, it's in perfect condition, 40K miles. Only problem I've found is the horn doesn't work. I switched out the horn and that isn't the problem....also, the fuse is good. Any suggestions? Is there a relay? Where? How do I test?
Ok, this may sound stupid, but what part of the wheel are you pushing to blow the horn ? If you push in the middle, like I do from habit, you get no sound. It's also the airbag and that's what's in the middle. The horn buttons are along the lower edge, and mine are pretty picky about being pushed in exactly the right spot before they work.
I only suggest this because it's a new car to you, and I know it's hard to get used to.
 

·
Registered
Joined
·
520 Posts
MartyK said:
Hi,
New to the forum and new proud owner. My 90 year old aunt gave me her 92 Eldorado, it's in perfect condition, 40K miles. Only problem I've found is the horn doesn't work. I switched out the horn and that isn't the problem....also, the fuse is good. Any suggestions? Is there a relay? Where? How do I test?
I know there's a relay, and I think it's in the engine comp. fuse compartment. That's where they usually are anyway.
Sorry I can't tell you exactly.
 
1 - 4 of 4 Posts
Top