Cadillac Owners Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
1,805 Posts
Discussion Starter #1
I have been having problems with my car the past couple of days. First a taping started from the front drivers side of the engine. Then the idil would run real high when driving it. Plus the service engine soon light came on for a minute on saturday haven't seen that since. Any ideas???? :confused:
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #3
vanaisa said:
First check computer codes. Then we maybe know more about those problems...
How would i check the computer codes im new to the whole car with computers stuff used to own classics. any help???
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #5
vanaisa said:
I got into the diagonistic part but it didn't say anything was wrong (hope i did it right) anyone know if you can go to a GM dealer and get the info on those codes and what they mean per exact year and model???
 

·
Registered
Joined
·
522 Posts
JJhomer83 said:
I got into the diagonistic part but it didn't say anything was wrong (hope i did it right) anyone know if you can go to a GM dealer and get the info on those codes and what they mean per exact year and model???
Did you get any codes at all? If Check Engine light goes on, then there must be error code!
If you post codes here, we can say, what they mean - also they are in factory repair manual...
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #7
vanaisa said:
Did you get any codes at all? If Check Engine light goes on, then there must be error code!
If you post codes here, we can say, what they mean - also they are in factory repair manual...
when i went into the code mode the check engine light did go on, when i cycled through the codes it keep saying error on most codes or ECU? ECM?? i got a lot of that
 

·
Registered
Joined
·
522 Posts
JJhomer83 said:
when i went into the code mode the check engine light did go on, when i cycled through the codes it keep saying error on most codes or ECU? ECM?? i got a lot of that
Then it must be broken computer/MEM-CAL card in computer(ECM=Electronic Control Module)...or just corroded contacts/connectors.
Try clean them and check again. If nothing happens, then its broken memory card...and this messing some sensors - and idle isnt right...
But about this noise in front drivers side of the engine - check first engine belt...maybe this noise coming from alternator/or other bearings?
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #9
vanaisa said:
Then it must be broken computer/MEM-CAL card in computer(ECM=Electronic Control Module)...or just corroded contacts/connectors.
Try clean them and check again. If nothing happens, then its broken memory card...and this messing some sensors - and idle isnt right...
But about this noise in front drivers side of the engine - check first engine belt...maybe this noise coming from alternator/or other bearings?
just ran out and checked the belt it is fine with the bearings as well. how do i clean the contacts????
 

·
Registered
Joined
·
522 Posts
JJhomer83 said:
just ran out and checked the belt it is fine with the bearings as well. how do i clean the contacts????
This is bigger job...
ECM(little metal box) is located in the right front corner of the passenger compartment under the instrument panel. there are colour coded connectors attached to the ECM - try clean those and check then again....
A good factory repair manual will help you much. I recomend to buy one...
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #11
vanaisa said:
This is bigger job...
ECM(little metal box) is located in the right front corner of the passenger compartment under the instrument panel. there are colour coded connectors attached to the ECM - try clean those and check then again....
A good factory repair manual will help you much. I recomend to buy one...
Van...
thank you for your help i am thankful of your knowledge. is there a specific brand of repair manual or where to get one that you could point me in the right direction
 

·
Registered
Joined
·
522 Posts
Well, i have Haynes repair manual (#38031), but it is not explaining all areas (like transmission - "it must be repaired in special shops blah, blah"), but in most of cases its useful.
Electrical and sensors chapters are almost perfect, others are good...
For usual and daily use its OK, but i´m sure, someone here can recommend better and sophisticated manuals....
For my ´67 Eldo i bought CD from Gearhead Cafe it is IMO way better choice (it contains more books too) - you need only good printer.
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #13
vanaisa said:
Well, i have Haynes repair manual (#38031), but it is not explaining all areas (like transmission - "it must be repaired in special shops blah, blah"), but in most of cases its useful.
Electrical and sensors chapters are almost perfect, others are good...
For usual and daily use its OK, but i´m sure, someone here can recommend better and sophisticated manuals....
For my ´67 Eldo i bought CD from Gearhead Cafe it is IMO way better choice (it contains more books too) - you need only good printer.

Where did you learn sooo much about Eldordos. Like you probably know i have a 92 w/ 4.9 and i want to know everything about it b/c i love working on cars. I don't have much money so i like FREE information. If you have any websites that you recommend besides this one that would be much appricated
 

·
Registered
Joined
·
522 Posts
I learned with working/repairing my car - and it is´nt so much, as you think :) I had to learn many things, cause we dont have here good Cadillac services. One and only is too high priced and they repair better Saab and Opels, than Cadillacs (they know only, where put oil and gas, i think ).
But in internet you must find lots of good sites (this site of course too :thumbsup: ) - you just find a bit here and a bit there.
This is one Very good site
Here is good site about sensors and what they do
 

·
Registered
Joined
·
520 Posts
JJhomer83 said:
Van...
thank you for your help i am thankful of your knowledge. is there a specific brand of repair manual or where to get one that you could point me in the right direction
I have a 92 Eldorado myself, it's a quantum leap forward from the 87 I had a few years ago. As far as a manual goes the only one I could find for a 92 is a Chilton's. It's not great but it knows more than I do. They're constantly on Ebay, and try Half.com for a used one. The car's also old enough that they should be showing up in used book stores by now.
Fortunatley, I haven't had the problems you have so I can't really help. But in the past I've been able to call a parts store and ask what individual codes mean.
Good luck.
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #16
got some codes that just popped up
the first one that says current is A011- I looked it up and it said high side temp circuit any clue what that means????

the others are in history
e091
e098
a040
if anyone can help me that would be great i am at a loss here
thanks
 

·
Registered
Joined
·
520 Posts
JJhomer83 said:
got some codes that just popped up
the first one that says current is A011- I looked it up and it said high side temp circuit any clue what that means????

the others are in history
e091
e098
a040
if anyone can help me that would be great i am at a loss here
thanks
My book doesn't list any codes starting with A. Sorry. But the high side circuit may be in the A\C system.
The 091 says PRNDL switch problem.
098 says High RPM P/N to D/R shift under ISC.
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #18
bob2231 said:
My book doesn't list any codes starting with A. Sorry. But the high side circuit may be in the A\C system.
The 091 says PRNDL switch problem.
098 says High RPM P/N to D/R shift under ISC.
can anyone help me out and let me know how to fix these codes??
Im getting desperate, can't afford garage labor
 

·
Registered
Joined
·
47 Posts
JJhomer83 said:
can anyone help me out and let me know how to fix these codes??
Im getting desperate, can't afford garage labor
Going off what is being said-091 code PRNDL- the computer is not seeing the correct gear selection coming out of the PRNDL switch. It could be out of adjustment, this isnt that bad. The 098- high rpm is the computer seeing a high rpm reading when you select a gear from park. This is usually caused by the ISC motor being bad. If you said you noticed it running at high rpms, this could very well be your problem. Get yourself a factory shop manual. Hynes/chiltons are no damn good. There are steps for replacing the ISC motor- more than just replacing it- You need to let the computer relearn the settings.
 

·
Registered
Joined
·
1,805 Posts
Discussion Starter #20
FYI to all of you.

The E091 - PRNDL switch problem
it has effected my e-brake. to disengage the ebrake your supposed to put the car in gear. I did that and it doesn't come off i have to manually do it.

The E098 - High RPM P/N to D/R shift under ISC
It has effected my idle. My car stays at a constant Idle for a lot longer than it should

The A011 - high side temp circuit
This could also be effecting my idle

Anyone know how to correct these problems that would be much appricated. I am soo lost on these problems and i can't afford to pay a garage.
 
1 - 20 of 21 Posts
About this Discussion
20 Replies
5 Participants
therock0051
Top