Cadillac Owners Forum banner

1 - 20 of 28 Posts

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #1
Ok ive changed o2 sensor,plugs,wires, found out Fuel Pressure Regulator had gas going in the vacuum line replaced that yesterday. I thought for sure it was the problem but it wasnt called mechanic he said i have to give it time for the gas to evaporate or burn off. He said my cap and rotor didnt need to be changed. So now im clueless what it could be i had the tps sensor changed but i dont know if its adjusted right the car is running great for a average person but sometime i like to hit them high rpms but it just doesn't it seem like its pulling a trailer when floored.
 

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #2
Also i have flow masters 80 series so i definitely wanna get this lag fixed it sounds good when cruising but when i gain speed it sound dull because its accelerating slow but trying to get past lag
 

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #4
Lol no i was hoping it was the regulator but that would be next i forgot you guys suggested that :neutral_face:
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
Did you check your pressure when you swapped FPR
 

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #6
Ranger i went to the muffler shop the mechanic said my cat isn't clogged and have good pressure. Now im lost. E53 came back distributor signal lost. Would that cause low horse power and sould i readjusted tps?
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
That E53 is really vague. On your 92 there is a cam sensor in the distributor, and if it goes bad then it could make the car run in default mode, but there is a specific code for that. There's also an ignition control module in there, but usually those just make the car die instead of running poorly.

Any other codes?
 

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #9
Ehall no, just 2 "F" codes one low refrigerant and the other PNDR error (just need adjustment) im going to mess with the tps sensor thats all i think it could be.
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
bad ignition module can make it run really bad at high RPM, basically misfiring a lot but not enough to kill the engine.

does it get worse when engine is warmed up?
 

·
Registered
1991 Cadillac Sedan deVille
Joined
·
591 Posts
E.5.3 could be pickup coil (crankshaft position sensor), hall-effect switch (camshaft position sensor), or the ICM (Ignition Control Module). To test the pickup coil - disconnect it from the ICM and measure the resistance with an Ohm meter (specs are 500-1500 Ohms). Also check to see if any of the leads are grounded to the distributor body - none of them should. To test the hall-effect switch you'd have to dig in the FSM to find the procedure (or I could try to find it for you and post it - let me know). To test the module go to any big auto parts chain store and they will run the tests on a special machine. Make sure the test is run a few times so the module heats up (most of them will be fine cold but will start failing as they heat up).
 

·
Registered
1991 Cadillac Sedan deVille
Joined
·
591 Posts
That's what it's used for on the 4.9l. Can show you the FSM if you don't believe me, MoistCabbage.
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
That's what it's used for on the 4.9l. Can show you the FSM if you don't believe me, MoistCabbage.
Can I see it? I don't have the 4.9 FSMs. Curious not doubting
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
ah, pickup coil, not ignition coil

neat
 

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #17
Ehall it runs good it just doesn't get that torque it used to get. Maybe its just age. Im going to mess with the tps sensor today and im going to do a video test drive so you could see what i mean.
 

·
Registered
1992 Cadillac Sedan DeVille, 2005 Escalade Ext
Joined
·
175 Posts
Discussion Starter #19
Mc_marto also i keep getting this e53 distributor signal lost code.
 
1 - 20 of 28 Posts
Top