Cadillac Owners Forum banner

91 Seville Running Horrible...

2329 Views 21 Replies 8 Participants Last post by  Unforgiven33
91 Seville with 4.9

Lately it has been getting poor gas mileage and the exhaust smelt rich and the smell was coming into the car. So had it diagnosed and changed out the front O2 Sensor, ECT Sensor, Thermostat, Spark Plugs and Distributor Cap. Still ran rich and got poor gas mileage. Now it has begun to run extremely poorly. It barely gets to 20 mph and it doesnt even have the power to get up a hill and it gets about 4 miles per gallon. So it's been taken to a few shops to try to figure it out and none of them know.

Then today it was taken to another shop and when they went to pull it into the shop, it wouldnt start. Turned out both the injector fuses had blown. So now its home and no shop in the area can tell me whats wrong with it. Since the injector fuses blew, I am starting to suspect them. No check engine lights. It did backfire once, so this thing must be running SUPPPPER rich.

Basically, anyone have any ideas? I am mechanically inclined. Next things on my list to do are to test fuel pressure, then pull the rails off and see if any of the injectors are leaking by when the fuel system is primed, and then to do a spray pattern test on them. Am I headed in the right direction?

Also, with regards to the distributor, I did trace all spark plug wires to the right spot in the right firing order. My question is that one the distributor cap, right side there is a 3 wire plug that plugs up into the cap and then a little white plug with a single red wire going into it that plugs next to the 3 wire plug, but there is then a spot open next to the white plug that it looks like a wire should go into, but i can't find any stray wires that go there. Is that spot supposed to be open next to the white plug or am I just not finding the wire?
1 - 4 of 22 Posts
Injectors are a known fail point on these cars, do you know how to test them?
Fyi when I got my '91 STS five injectors were bad at 128k miles...
The fsm has a procedure to check what injectors are completely dead.
I think you need a set of injectors resistance isn't right on 5 of em.
Head to a junkyard and pull a set from a 4.6 town car. I did it two years ago and haven't had a issue.
1 - 4 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top