Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
2007 DTS
Joined
·
371 Posts
Discussion Starter #1
My 91 Eldo just had the dash go dark. No lights anywhere. No codes either. It runs and drives OK but the dash going dark is a problem. It did it while I was driving and came back by itself. It did it numerous times but never quit running. I have the battery on a charger to see if maybe it is the problem. Any suggestions?
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,827 Posts
My 91 Eldo just had the dash go dark. No lights anywhere. No codes either. It runs and drives OK but the dash going dark is a problem. It did it while I was driving and came back by itself. It did it numerous times but never quit running. I have the battery on a charger to see if maybe it is the problem. Any suggestions?
=======================
could be as simple as a loose/dirty ground -
 

·
2007 DTS
Joined
·
371 Posts
Discussion Starter #3
I did have the battery out to fix a hose. I will check the terminals to make sure they are clean and tight. I also have the following codes but doubt if they have anything to do with it.
E013-right o2 sensor not ready
E052-ECM memory
B120-twilight sentinel
B121-" "
B448- AC issue (not connected or working)
B552- battery was disconnected
 

·
2007 DTS
Joined
·
371 Posts
Discussion Starter #5
I removed and installed the battery cables and all seems right. I drove it about 10 miles and the dash was fine.
 

·
2007 DTS
Joined
·
371 Posts
Discussion Starter #7
The dimmer has no affect. When the dash is lit, the dimmer works as usual. I think it was a bad ground from the battery. Time will tell.
 

·
Registered
Joined
·
131 Posts
I had that problem on my '88 eldo. It was the Central Power Supply. Also, I just experienced this on my '92 Toronado and that time it was the photocell that sit at the base of the windshield in the center. I saw that you have an error code for the twilight sentinel which the aforementioned photocell plays a big role in. Hopefully you fixed your problem.
 
1 - 8 of 8 Posts
Top