Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
91 sedan deville 4.9L
Joined
·
7 Posts
Discussion Starter #1
I bought a 91 deville last week super deal! I know a little bit about cars and im a auto mech student. I have a problem with my deville and i dont understand ...I start her up she idles fine but runs rich, i drive off and shes fine at low acceleration, i pull on to the main street to take off and she rides like a champ (cold), I drive 10-15 miles in 80degree weather and to normal driving conditions, and she hesitates as i accelerate so bad she almost dies out untill i ease up on the gas then its repeats more and more as i drive untill shes dying out as i pull off......i wait 20-40mins and shes fine again till she warms up ....?


i cleaned the throttle body and used much fuel additives


details:

4.9l rebuild
trans rebuild

codes:

E52
E53
E71
F48
HI:
E9.5
LO:
E1.2
E9.6
then
7.0


I notice a main air hose on the head connected to the air filter has riped tip at heads behind air filter.

and a bad ground for my started which im correcting in the morning

I dont know if i did a bad thing by resting my my obd and these are the new codes.
E48
F90
7.0

i will be flushing the coolant also
can some tell me what you think?:crying2:
 

·
Registered
1990 Deville w/ 250,000 mi
Joined
·
280 Posts
E052 ....................................................... PCM Memory Reset
E053 ........................................... Distributor Signal Interrupt
E071 ................................................ Intermittent MAP Signal
E095 .................................................. Engine Stall Detected
E096 ............................................ Torque Converter Overstress
E012 .................................................. No Distributor Signal
E048 ......................... Exhaust Gas Recirculation (EGR) system Problem

Your all kinds of F'ed up

I have an all data DIY account for my 90 deville 4.5L... would anything be helpful to this guy?? If so I can try and help out.
 

·
Registered
91 sedan deville 4.9L
Joined
·
7 Posts
Discussion Starter #3
hey i only paid $650 for her and she had no fdc or ecc lights, shift nob was off, and i had to shift her manually because shift lever was disconnected... great int and Ext Paint ....10,000miles rebuild 4.9& Trans........I just want to stop here from dying out while im driving.....thats it!..can anyone help me
 

·
Registered
1990 Deville w/ 250,000 mi
Joined
·
280 Posts
I wasn't hatin' on ya

Hopefully I can help out, dunno if 4.5 and 4.9 are similar or totally different.

whats the total mileage?
 

·
Registered
1991 ELDORADO (R.I.P.); 1995 Sedan Deville
Joined
·
341 Posts
A few things to check would be your fuel pump, the hall effect sensor (it's inside the distributor), and the map sensor (this includes the vacumn line connected to it that leads to the engine). More knowledgeble members than myself will likely respond with advice soon. Hope you get it going smoothly again!!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,621 Posts
i cleaned the throttle body and used much fuel additives
Those additives are strong and too much can dissolve the insulating varnish on the pump and injector windings. Check your fuel pressure (should be somewhere around 45 psi). Use one with a long hose duct taped to the windshield and watch the fuel pressure when you accelerate. If it falls off real bad, you have a failing pump.
 

·
Registered
91 sedan deville 4.9L
Joined
·
7 Posts
Discussion Starter #8
this morning i flushed her out and put in freash coolant ....the i was messing with the map sensor "pop" a f'ing short and it was the trigger of the codes because with a wiggle she died but fired up fine ...also i notice my mounts are bad so the motor jumps up on heavy acceleration "pop" .....$1 black electrical tape.....she's a beats no dying out....also i kept playing around with the egr valve and no more rich exhaust fumes .....now im putting synthetic oil& filter and new plugs and wires ......thanks 4 now caddy owners!
 

·
Registered
91 sedan deville 4.9L
Joined
·
7 Posts
Discussion Starter #10
$500 for a fuel pump and sensor that was shorted ....is why this car kept dying out ....



Does anyone know the factory idle setting for diagnostic reading for p.01 because im getting a 2.5 and my smog failed for a low idle ......how can I speed it up if it has a auto idle control ?
 

·
Registered
1990 Deville w/ 250,000 mi
Joined
·
280 Posts
A few things to check would be your fuel pump, the hall effect sensor (it's inside the distributor), and the map sensor (this includes the vacumn line connected to it that leads to the engine). More knowledgeble members than myself will likely respond with advice soon. Hope you get it going smoothly again!!
what does the hall effect sensor do?
 

·
Registered
1991 Cadillac DeVille
Joined
·
1 Posts
Oh My Gosh! We are having the same problems. We put in a new ECM, Battery, spark plugs, rotor and cap and wires, disconnected O2 sensor and checked the starter which seems to trip fine with wrench...yet...now it won't turn over at all now! before it ran and died all the time...but now it just won't even turn over...GRRRR... please let me know what you find out!
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,082 Posts
Oh My Gosh! We are having the same problems. We put in a new ECM, Battery, spark plugs, rotor and cap and wires, disconnected O2 sensor and checked the starter which seems to trip fine with wrench...yet...now it won't turn over at all now! before it ran and died all the time...but now it just won't even turn over...GRRRR... please let me know what you find out!
=========================
don't hold your breath waiting for a reply - this thread died more than 8 YEARS ago -
 
1 - 14 of 14 Posts
Top