Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Its a '87 deville with only 70k miles..bought brand new and driven on the hwy alot lately. Last night I noticed the "Stop/Check oil" light came on after I came to a light.. But the weird thing is, the light only dlickers on when the car is in "D" and its sitting at a standstill. I checked the oil and added a quart cause usually the car will lose a 1/2-1 quart in its 3k mile oil change interval due to a slow leak. An Oil change is only 350 miles away but I went ahead and added a quart. Drove the car around and the light still came on..I pulled over and checked the oil which was fine. Parked it at the house for an hr and then went out and drove it around.. but the light never came back on.. :confused: hmmm well hopefully it wont come back on lol.. The motor wasnt making any kinds of noises either. Have you guys had this happen yet? Where the oil light will only come on in "D" at a standstill? But once u start driving the light is totally gone but only comes back when u come to a stop.. thanks :) Its the 4.1 V8 with the electronic cluster
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Hmmm I dont know, but it is something Id concern myself with...... Since you bought it new, Id assume oil has been changed every ~3k, so clogging really isnt an option...

Do the 87 SDV have OBD?? If so, you might check the codes, but Im not sure if it has it!!!

It might just be a switch or sensor......
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,737 Posts
The Oil Light Coming On Or Flickering In D Is Because Thats The Lowest Idle Speed, Lower Than Park. Have The Car Towed To A Shop And Have Them Verify Oil Pressure With A Gauge With The Engine At Normal Temperature. Oil Lights Generally Come On When The Sender Sees Less Than 10 Lb. Pressure. I Tend To Think Its A Weak Oil Pressure Sender Which Is Located, I Believe At The Oil Filter Adaptor. You Dont Want To Guess At This Repair, Have It Diagnosed. Hope Its The Sender. Report Back, Bill.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
Hmmm..very strange.. drove the car around a little in the morning and the light never came on.. I ended up putting around 90 miles on it today and the light never came on. i will still keep a guard up though.. but I'm glad it never came back on! :)
 

·
Registered
Joined
·
7 Posts
Bobby C 01TA said:
Hmmm..very strange.. drove the car around a little in the morning and the light never came on.. I ended up putting around 90 miles on it today and the light never came on. i will still keep a guard up though.. but I'm glad it never came back on! :)


Had this same problem on an 83 Caprice when it was young (6 years/107,000 miles). The problem was the pressure-relief spring in the oil pump. At speed it kept up enough oil pressure to turn off the sender, but went down to near zero at idle.

The fix was to install a new oil pump, which I did myself for about $75. The spring would have been 50 cents, but they don't sell those separately.

Best to get a cheap analog oil pressure gauge from the car parts store and hook it up it so you can see what the pressure really is at everything from idle to 3,000 RPM. With these few miles and the good care it has gotten, it is probably not something horrid like worn-out rod and main bearings.

But if you go around without enough oil pressure, that is subject to change!

Good luck with it. Hopefully it is just a bad sender or gauge.

Jeff
 
1 - 5 of 5 Posts
Top