Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I bought a 86 fleetwood brougham that i bought from someone that had it sitting for about a year. at first it ran well but it was a little weak. a couple months after i bought it it began to die about 15 minutes into driving it in the morning, i would try to start it but it would just crank over or start and run really bad. later in the day it would start with a big cloud of dark smoke. I changed the fuel filter and found a few craked vacuum lines so i fixed that and it ran better and didn't die. Now a few weeks later it will not go above about 30mph and it wont go up any hill with out slowing down and dying. What should i do? it sounds fuel related but I dont know what to do from here. any help or suggestions would be great. thanks in advance.
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
It's probably always going to be weak, it's a 4000 pound car with a 5.0L V8 rated at 140hp. But maybe it's time for a carb rebuild, or at least some good carb cleaner.
 

·
Registered
Joined
·
4 Posts
I had this same problem. Turns out the timing was retarded by 20 degrees. The computer tries to adjust and keeps getting worse.

Secondly, the delay in power can come from one or both of the bad choke modules. During my diagnosis I had to leave a pencil in the carb to keep the choke open in order to drive it once it was warmed up.

Ultimately, it is a very weak engine for this big mamba jahamba car. Once I fixed the two chokes and had the computer reset, it ran 100% better which was unfortunately still not all that powerful and I still have a very stuck distributor. Just have to do it and get it done with.
 
1 - 3 of 3 Posts
Top