Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
1987 Brougham 1978 Seville
Joined
·
254 Posts
Discussion Starter #1
Hello all. I am new to this so be patient. I have an 84 Eldo Convertable and took it to get it smogged here in CA. They could not keep it at the speed on the dyno they needed to. It would take off then slow down. If he gave it more gas it would speed up quite a bit then once again slow down without him adjusting the accelerator. ANy ideas what could cause this?? Thanks:hmm:
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,585 Posts
Since you are technically in the correct forum I am not going to move it but you might get more help in the HT4100 forum. I have forgotten most of what I knew about that engine, but it sounds like it may be a vacuum leak. It has been a loooong time since I've had one.
 

·
Registered
1999 STS - diamond white
Joined
·
5,229 Posts
vacuum leak is the first thing to come to mind. An engine that old has to have some old, cracked and brittle hoses.
 

·
Registered
Joined
·
108 Posts
Do yourself a favor - replace all the vacuum hoses - it's a pain but in the long run it beats the heck out of trying to figure out which old hose is leaking - also check the coolant hoses - if any of 'em are bad replace the whole bunch of 'em at the same time. It isn't expensive, doesn't take much time and will probably inspire you to get the engine steam cleaned by the time you're done (if not before!)
On a 21 year old vehicle it'd be unnatural for the vacuum hoses to still be in good shape ...

Steve
 
1 - 5 of 5 Posts
Top