Cadillac Owners Forum banner

1 - 20 of 24 Posts

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #1
Hello All,
I'm new here and have searched already so just be patient with me. With that being said, this is my first Caddy. It's a 84 Deville w/4.1 and it wont start. Long story short 2nd fuel pump later and i am now hearing it prime when key in ignition. Changed fuel filter, tightened it all up, let it prime several times to re-pressurize system and fuel line from filter, to solid line has hole and leaks. Change line, try to start car and will not start. The car turns over, and will start every time with starting fluid but not seeing fuel squirt from the 2 injectors. What else can i look at as the problem. Thanks
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #5
So i unscrew the fuel line, crank the car fuel everywhere. So there's no clog there, so it could be the injectors? what other areas should i look at now? does the injectors have a fuse or relay or etc? i did also take the injector housing off.
 

·
Registered
87 Brougham, 1969 Calais, 95 FWB, 07 SRX, 07 ESV
Joined
·
4,246 Posts
if you're getting fuel pumping out then I'd say the problem is in the injectors. Maybe replace the injectors and see what that nets you.
 

·
Super Moderator
2014 ELR
Joined
·
9,663 Posts
Before you replace the injectors, check the fuse first, then test the pressure. Just because you have gas doesn't mean you have the correct pressure.
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #8
ok how do i check pressure? with that valve (i believe it's called a schrader valve) and is there a special tool for it, and which fuse is for the injectors, because i cannot find it in the manual and my under dash fuse box as no cover.
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #10
i checked all the fuses they all worked except one, and not even sure if that one is supposed to get power. But with the injectors out and fuel lines loose i can't crank the car and throw fuel everywhere. With the ignition on can i put a test light on the fuel injector plugs, will it get power like that or do i have to crank the car? what do you guys suspect the problem is from this point?
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #11
update, replaced the fuse that didn't light with a fuse that did initially light and that fuse didn't light so must be ok. Also i used the test light and there is power at both the injector connections. I also did a diagnostic check with the climate control and it displayed -1.8.8, then 26, 52 and 53, the sequence flashed like two or three times and the final # was .7.0, so don't know if that means anything to anyone.
 

·
Registered
84 Coupe w/500
Joined
·
5,660 Posts
Have someone turn the car over while you look at the injectors. You should be able to see fuel shooting out the bottom of the injectors into the intake.
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #13
i tried that and nothing was squirting out, so i have since removed the main housing that contains the 2 injectors. So im looking on youtube to try and make something where i can test to see if injectors will spray. And i'm trying to pinpoint problem to either injectors or ecm.
 

·
Registered
84 Coupe w/500
Joined
·
5,660 Posts
You can hear injector with an automotive stethoscope. Cheap tool and easy to use. Maybe leave the test light on the injector wiring while you turn it over? See if the light pulses.
 

·
Registered
70 Deville 77 Fleet 78 Seville 92 Deville 03 Deville
Joined
·
3,310 Posts
I have a Buick with this issue and I haven't figured it out yet. I'm hoping to get a clue here. I never thought of the fuel injection fuses. A lot of Caddy's and Buicks have another set of fuses under the hush panel on the passenger side. I don't know if the 84 Deville does or not. You should try to find those fuel injection fuses though. It does sound like the fuel injectors just aren't getting power like mine.
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #16
I have yet to test injectors but i have them out and will do so very soon. I believe that it's going to be the ecm, but i want to be thorough so i don't have to repeat any steps. I'm having a hard time finding a tube large enough to encase the injectors so that i can pressurize the tube, and apply power to check the spray pattern. So ill let you guys know the results from the injector test.
 

·
Registered
84 deville
Joined
·
9 Posts
Discussion Starter #19
ok i understand fuel pressure is essential, and a few ppl said to check the pressure, but i asked earlier how to check pressure with the tbi housing removed? or do i have to put it back and test that way?
 
1 - 20 of 24 Posts
Top