Cadillac Owners Forum banner

741 - 757 of 757 Posts

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #741
That's sounds pretty close. They say about 20% loss thru drivetrain which would be around 420hp. The plan was to do two runs at a time and adjust timing from there. First adjustment put me pretty close, second adjustment was gonna dial me in but never made it that far. I had a lot of fun, live bands, great food, hundreds of cars, burnout contest....
 

·
Registered
02 Escalade | 02 Corvette "Goldilocks" | 03 Blazer 4x4 | 92 Caprice Wagon LS1/T56
Joined
·
19,738 Posts
That's pretty awesome. P.S. Have you downloaded the Chrome browser extension to get all your photobucket pictures working?
 

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #743
I havent. I thought you posted a link but I have safari on my apple computer. Not sure. The whole photo bucket thing just upsets me when I think about it. I took almost 200 photos this weekend, including the other brougham setup for drifting(roll cage, big ebrake, 355ci, ford 8.8, ladder bars) but haven't found time to find another host.
 

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #745
All back together now. I was having issues with big puddles of oil under the car after I turn it off and it turned out to be the white wrench off K&N oil filter. Not sure if it was a defect but it didnt work and was causing a strain on the oil pump and a loud whinning sound. Took it off and saw that it was collapsing. Even the metal shell started to pull inside. put a racing radiator in it, redid some wiring, got a B&M shifter, driveshaft safety loop and have a guy coming to do some custom headers.
 

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #746
Well yall, I'm still at it with this car. Just came from cash days a couple weeks ago where it ran its best time to date. Motor is still running really strong. I have a video but it's says it's too large to upload. It's about 50 sec long if someone knows how I can load it.
 

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #750
Thanks. I can get the RT down to .23ish. Running under 8 seconds now eight mile. I've been beating the camaros and mustangs but the corvettes are still a second faster. One day.
 

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #752
3.90, seems pretty good for eigth mile, maybe a twinkle bit too much, guessing 3.73 would be perfect for eigth. Definately runs out too fast in quarter.
 

·
Super Moderator
2014 ELR
Joined
·
10,024 Posts
Damn, I was going to suggest trying 4.10s or 4.56s. I have 4.10s in my T56 car. What's your RPM through the traps?
 

·
Registered
84 Coupe w/500
Joined
·
5,670 Posts
Discussion Starter #754
You know, I'm not sure. And now you have me wondering if I'm going the wrong way with my gears.... I think I am. I've never thought to look down at my gauge, just by feel. I might try to get out there for one more test and tune before the year ends. Rookie stuff but I'm learning.
 

·
Super Moderator
2014 ELR
Joined
·
10,024 Posts
Yes, tach time. Then look at RPM/red line in top gear, and add in the tire height, then work the calc with the gears. Lower gears will get you out of the hole.
 
741 - 757 of 757 Posts
Top