Cadillac Owners Forum banner

661 - 680 of 759 Posts

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
Cool, keep up the good work. I also bought another engine and was thinking of porting the heads but not sure now. I am afraid it's going to take me 12 hours per head, not mentioning the risk of going through.
When are you taking it back to the strip?

Props to you for getting your hands in the tranny, not sure I would have the courage to do it.
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #662
If weather is good, I'll be going to an 1/8th mile track ON SATURDAY! I'm geeked! I still have the old motor in but I need to get better times and learn how to tune and time my engine on the track.
 

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
So did you end up going to tthe track? How was it?
By the way which engine mounts do you have? Are they the ones that came with your car? Was it the 307 you initially had?
I will upgrade from the 5.3 to a 6.0 and wanted to see if you used same mounts or did you change them?
With the torque that you have, the car must be a goof test bench for engine mounts:)
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #665
I went but didn't bring the car. It was an eighth mile track but I still should have brought the car. My girl said it would be too hectic to bring the car and four kids. She soon learned that we should have brought the car. I hope to go to the quarter mile this weekend but we planned another trip for the 5th to the eighth mile. This motor should be going faster then it is and I'm gonna make it....and then take it out for the new motor to go in.
 

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
nice, can't wait for the numbers:)

----------

I hope that tub is baffled which would make it a bit uncomfortable
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #667
Was that you that brought your car to the track? What numbers did you get? You got the 5.3 LS motor in yours right?
 

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
yes, it was my car. I think the best it did was about a 14.5 or 14.6. With 3;73 gears, 4l60E transmission and Impala SS wheels with old Nitto 555s. I regret the Impala wheels, I did not know they are so freaking heavy. I also had a cam. I expected better, closer to 14.2. I have a stock converter though so maybe with a 3000 ish stall I would have been able to get closer to the 14.2 mark. Good tires might have helped too.
Now I bought a 6.0l to swap in but I am waiting to fix my bike and sell it so I can afford a good converter and do both at the same time.
OTOH I put it for sale, if it does sell I'd like to get something lighter but 4 doors and rectangular still. I shouldn't say it but an old Hyundai Stellar with a cammed 6.0l would be a funny toy.
I love the Caddy, it is very addictive and fun handling for what it is but I cannot have two toys and the quick bug is gnawing. I often find myself thinking of something lighter. But if it doesn't sell by the time I sell the bike the 6.0l goes in and I end up keeping it for a while. I just don't want to spend the 1000 dollars on fixing the roof, it starts having cracks so I don't take it if there's any chance it rains which limits my days using it.
Also the 4L60e isn't expected to hold for long behind a cammed 6.0L

How about your engine mounts. Any problems with them yet? Still on the originals?
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #669
Nice projects you have going on. Are the nittos slicks?

Motor mounts are doing okay I think but I do have a clunk when I switch gears so you have me wondering now.
 

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
The though of replacing mine at the same time of swapping the new engine in. I find them a bit on the smallish side, even more so when you consider the torque on your engine. Like I said your car is a good test for them:)
I'll check if there are stronger ones and how much they cost.
For now they're ok on mine. I hope yours are ok too
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #671
Mine were loose on the engine side. Thanks for the heads up. The bolts that bolt the engine side mounts to the engine were loose.
 

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
cool, glad you found where the clunk was coming from. I hate clunks. when will you put the new engine in? Can't wait to know how quick it will be.
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #673
I'm not sure when the new engine will be going in but you know how engine time frames are...add 18 months to your original estimate lol. Probably be in before the snow flies.

----------

And since there hasn't been a pic in a couple pages...the intake sitting on top the motor. Fun stuff

 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #674
Had a blast. Probably did 10 hits and they let me take all of my kids down separately. Fastest time I got was 8.98 with 1.99 sixty foot at 79mph. One thing I do like about the eighth mile is that you don't run your car so hard. Car did good, tranny did good, no overheating, no problems. Towed it there on a uhaul trailer. It was 88 degrees and 95% humidity, just baked all day. Big turnout, had to have been 75 cars there by the time I left.

Not sure who the hotty is in the start of the video but she was rolling a 6 second pink motorcycle.

http://s935.photobucket.com/user/csbuckn/media/20150905_142644.mp4.html
 

·
Registered
1987 Brougham 5.3 Vortec, 4L60E transmission
Joined
·
334 Posts
nice, you ran on your drag slicks?
I don't think I'll be going this year to a track, but next one definitely.

Do you ever sleep?:) How do you find the time with 4 kids to work on the car. With only one I find it much more difficult than before.
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #677
It's hard to, specially since I work out of my garage at night.

I did these on drag slicks. Talking to some people, I don't think I'm launching correctly. I stage at 2k rpm and hit the gas most way down on green. People are saying I should stage at 12-1500 and floor it at green. Thinking about it, it does seem like it would launch harder like that. Think I have one more visit this year, going with a friend and his s10 next month. Hopefully bring the delta with the 454 also. Just needs the new posi put in and he should be able to bring it.
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #678
So I'm making some progress on the new motor. Got most of the bottom half in and now I'm waiting on a cam. Not sure what I'll do for a cam but it will be pretty big.

A few pictures...



Forged rods and pistons, pretty cool. Hopefully they give me some POWA!


They look so pretty...


Oil balancing line to get more oil to the rear. Some will say the motor starves at the back and this should keep it in check.
 

·
Registered
1983 FWB (Mac), 1981 SDV (Junkyard Dog)
Joined
·
734 Posts
Sam, have you tried a fit on your starter? That oil line looks as if it might interfere with mounting the starter. The oil line clip seems to be using the starter support bracket bolt hole.

Cheers...............R.
 

·
Registered
84 Coupe w/500
Joined
·
5,671 Posts
Discussion Starter #680
I haven't tried yet because I haven't got one yet. I'll have a mini starter that won't use the rear support but I will check it as soon as I get one. Thanks, I could see it getting in the way of the stock starter.
 
661 - 680 of 759 Posts
Top