Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
New guy got a 82 coupe deville,IT ran fine then my check engine light came on and it ran real ruff and the idle is harsh.Well after it gets warmed up it cuts off .Was told it could be the MAP sensor but i cant fimnd where its at.Does anyone know where its located and how much a new one will cost.
 

·
Registered
Joined
·
6,471 Posts
Did you get a MAP code that would lead you to believe the sensor is the problem? As for the sensor location, I believe it's under the dash on the right side. It's a little black block about the size and shape of a domino. It has a black plastic hose connected to it. It's fairly common to have them go bad from getting fouled by raw gasoline. It gets there from condenced fuel vapors in the hose. In early applications, they were improperly mounted LOWER than the throttle body/carburator and therefore condenced fuel vapor just tracked to the sensor and destroyed it. If the sensor is bad, replace it and remount it in a higher location. Make sure that no part of the hose is HIGHER than the sensor or it will happen again. I usually mounted mine out in the engine compartment (thereby reducing the length of the hose to minimum) and just ran an extension to the wiring.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes i did get a map code so i just guessed it was bad but if its cheap ill go ahead and get a new one,If its not bad what could be causing the harsh running ,low gas milage and it cutting off?
 
1 - 4 of 4 Posts
Top