Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #1
Hey hows it goin this is my first post on here but ive been checking up for a while n have read alot of good info. well to start out i have a 1994 deville with a 4.9, i had the tranny rebuilt the first week of the year because it was slipping no other problems with the car. When i got it back it would slightly surge when its cruising at about 30-35 mph and then again around 45-50 and the rpm would be around 1100 and the car would have no go until it downshifts and the tcc rarely locked up on the freeway and when it did the rpm would be about 1600 doing 60 mph which didnt bother me but seemed a little low. i took it back. A week later they told me i can pick it up, when i got there they said it was making a noise and it was related to the fuel injectors i was in a hurry to get work i i left it at that n took the car. i drove it 30 mins to work on the freeway no problem till i hit the exit ramp, the engine felt like it wanted to die out then rev back up when comming to a stop. after changing the fuel filter, checking the fuel pressure which was about 40 psi fuel injector cleaner, changed the tps, vacuum lines no change. when i drive maybe 3 sec after it hits second gear it feels like the tcc locks up and the car jerks, then goes into 3rd with the tcc awready locked same with 4th, then when stopping it does not want to unlock, so it jerks as it down shifts to each gear while bringing the rpm down to about 400 with each down shift then it revs back up as shifts to a lower gear. also after driving it for about 20 mins it does nopt lock up after each gear as much until you hit 44 mph and it locks but it will still stay locked and jerk until it gets into first gear. the cruise control turns off when you hit the brakes so im sure its not the switch , so does this sound like an internal problem with the tranny or could it be pcm related. it wasnt doing any of this before the tranny was rebuilt only slipping cus i changed the fluid which was almost black. also no codes except for suspension related. sorry for the long post! Thanks in advance
 

·
Registered
85 Coupe Deville 4.1 V8 & 4.3 V6 Deisel & 1970 Eldorado
Joined
·
773 Posts
Did they rebuild yours or just exchange yours for a rebuilt one. If they exchanged it, Then it is possible that they did not use the correct trans. I am pretty sure that different models of the 4t60-e had wiring plug changes. There is a tag on the transmission that indicates the model designation. You might check with a dealer to make sure that it is the correct one. (Would also be listed in the factory service manual)
 

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #3
they said they rebuilt mine not replaced, where would that tag be? i will be checking with the dealer. I have yet to get a factory service manual, Im thinking they rebuilt it with parts from a different model 4t60-e cus the gearing seems a little off on the freeway. thanks for the reply
 

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #5
Ok thats a no go i found the little plate with the info but it was all faded away, so ima match up the model the dealership gives me to what the shop says they put in, if that checks out would it be possible to throw a 4t40 or a 4t60 thats not electronic and hook up a tv cable or would that cause more problems, cus ive checked jus about everything, leading me back to the tranny
 

·
Registered
85 Coupe Deville 4.1 V8 & 4.3 V6 Deisel & 1970 Eldorado
Joined
·
773 Posts
While possible it would cause problems with the power train management system. You would get error codes and possibly a check engine light. This may cause you trouble with emission inspection (if you have it in your area).

I am a believer in trying to keep everything stock. (except a special purpose auto. Hot rod 4X4 etc)
If your transmission is not working correctly after a rebuild, Have the shop make it right. That is what a warranty is all about. I am sure you spent a fair amount of cash to get this fixed. If they give you any trouble, consider taking the car to another shop or dealer for an evaluation.

If all was working ok (except for the failure) before the rebuild, do not let them bully you into blaming the engine or computer. If that is what they claim, Make them prove it to you.

Good luck!
 

·
Registered
03 STS
Joined
·
2,527 Posts
seems issues with trans after rebuilds is very common. #1 problem with BBB. very complicated device and a PITA to fix multiple times. you gave shop money to diagnose problem, pulls trans, replace any bad parts and test drive. now it does not work right and they won't make it right.
 

·
Registered
99STS,2004 Jeep Liberty Renegade,98 Deville RIP
Joined
·
1,054 Posts
Most tranny shops work on the al a carte system, they only replace what is needed and not what is likely to fail. A 4t60e despite it being electronic is not a very complicated tranny at all. It sounds to me like a couple of things, first did they replace the TC or reuse yours, this is an al a carte thing, did they put the checkballs in the right channels? Did they flush the tranny coolant lines, it may just be contamination, the fluid as you say was very dark, that should point you in the right direction. The only differences between the 60e's were the gear ratios in the diff and a different tc. As you have had this puppy rebuilt, then take it back and as Mike Holmes says, Make it right.
 

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #10
Well they "said" they hollowed out the case and replaced everything the first time flushed the lines and radiator, the second time i took it back they said they replaced the tc, all sensors and wiring again, im taking it back hopefully this time they actually fix it, i jus wanted to get other opinions on what it could be but since it didnt have any problems till they touched it well.
 

·
Registered
03 STS
Joined
·
2,527 Posts
have had 4 grand prixs with 4t60 trans. just looked at 94 deville with bad trans. debating whether to buy it. tons of these trans out there. shop seems to be trying to help you. was there a fee to change TC and sensors? if not, than they are loosing money on you.
 

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #12
If its a reasonable price if get it, its a good car otherwise I wouldnt have spent the cash to rebuild the engine n tranny, as of now its all warranty work so yea they are losing time n moneyon this one
 

·
Registered
99STS,2004 Jeep Liberty Renegade,98 Deville RIP
Joined
·
1,054 Posts
The 4t60e is a tranny shops delight, a tranny that will fail at around the 150k mark approx and will need to be rebuilt. This is one of the shops bread and butter tranny's along with the chrysler fwd tranny from all those minivans they have sold in the past. Don't worry about them losing money on you, they have more than made it up with other rebuilds. Other than removing it, it is one of easiest to rebuild as long as you work in a clean evironment. They rebuilt it, they need to make sure it works.
 

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #14
im not too worried about them losing money on me i did my part when i handed them the cash to fix it, they havent done there part in fixing it, im sure this isnt the first 4t60e they built so i dont know whats going on, i jus dont wanna go another week with them having the car n returning it with another problem, also when i got the car back this last time there was grease stains all over the inside on the headliner in the seats sun visors, couple sensors werent even connected, i didnt notice till i got home n checked everything out
 

·
Registered
1994 Cadillac Deville 4.9, 1995 mazda millena
Joined
·
20 Posts
Discussion Starter #15
Awright i jus got my car back it, it turns out that the new solenoids they put in were bad so they replaced that an put in a different tc then the kind they put in before its all good now
 
1 - 15 of 15 Posts
Top