Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Cadillac
Joined
·
12 Posts
Discussion Starter #1
OK so i've been reading this forum for serveral hours trying to get some hint of what my problem is. My main issue is that i'm broke and owe too many people money to actually take my car somewhere to get it looked at. My car ran fine for several months, then the fuel presure regulator was leaking. Replaced it, and it wouldnt start... all though it was about 5 degrees out and it hadn't started in a month. Started it again this spring, and it's got a really rough idle and has about half the power it had before. Changed plugs, wires, oil, cap, rotor, and cleaned the fuel injectors and system. I checked the PCM and got a code 26. Changed the TPS and im still getting the error code. Wondering if I take it somewhere and have it calibrated .. or if it's not too difficult if I did it... could this possibly fix my issue? It's getting about 12MPG and feels like it's got 120hp... and idle's like i got a sick cam in it.. but without the benifits. I'd like to sell the car in a decent working condition and get something a bit more fuel efficient. Any input would be great!
 

·
Registered
Cadillac
Joined
·
12 Posts
Discussion Starter #3
No .. unfortunatly not. No one responded and i've been working a lot and have not had a chance to do anything with the car.

The latest development is that the throttle sticks and then the check engine light comes on. It will stick until I tap the gas, then it'll unstick and the check engine will go off. Also... it sometimes hesitates for about 2 or 3 seconds when accelerating. Obviouslly sounds like a TPS issue. I'm not sure if the one I installed failed already or what. But I am getting several error codes... 13 (o2 sensor ? but is that front or rear), 22 (tps), 26 (tps), 44 (o2 sensor again), and 70... more tps?

So i think im just gonna try fixing it again tomorrow. Can someone tell me the location of the rear o2 sensor on my beast? I might be trading this car for a 98 blazer.. but i dunno yet and if not i need to fix it. Thanks... mitch
 

·
Registered
Cadillac Seville 4.9L
Joined
·
24 Posts
the 02 sensors will cause poor mileage. On most 4.9's, the rear sensor is located on the rear bank. I haven't changed mine yet, so idk how hard it is to reach it.
 
1 - 4 of 4 Posts
Top