Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #1
My 91 deville will start and stall out right away,I have checked fuel pressure,replaced the control module,checked all fuses and relays,and checked for codes.I heard of a hall module may be my problem from a local parts store,any advice out there will be very nice.I also have a 1993 Allante,is it the same procedure as my deville to check for codes(through climate control)Thanks in advance for any tips.
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #2
just replaced ALL distibutor components today,still not working,this is frustrating and getting expensive.might be the computer????
 

·
Registered
76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
Joined
·
668 Posts
Could be bad TPS adjustment. Will the car start if you depress the pedal slightly? If so, I'd check this item. Your TPS may not be set up to let the engine rev up when first started (too far advanced).
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #4
wont stay running even if i depress the accelerator,almost seems like it is cutting the fuel supply,or whatever tells the injectors to fire is not working.Do these cars have a cam/or crank position sensor?this all seemed to happen after the serpintine belt flew apart,I have looked to see if anything got unpluged by the belt but i have yet to see any sensors on that side of the motor.
 

·
Registered
76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
Joined
·
668 Posts
Yes, there is a "hall effect" or cam sensor in the distributor. This could be the cause if your fuel pressure is in spec.
 

·
2007 DTS
2007 DTS, 1991 Eldorado(retired), 1999 Deville (retired)
Joined
·
371 Posts
I went htrough all of what you have with my 91 Eldo. I finally replaced the whole distributor and all is well!
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #7
Thanks to all for your advice!I will replace the whole distibutor tomorrow,I will let you know if it works.Once again a big THANKS for all who have helped me out.
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #8
running perfect! I poured some fuel in the throttle body,the caddy started and ran fine.drove it 10 miles no problems.Thankyou all for your advice!
 
1 - 8 of 8 Posts
Top