Cadillac Owners Forum banner

1 - 20 of 22 Posts

·
Registered
2017 XT5, 2010CTS, 2006 STS V
Joined
·
5 Posts
Discussion Starter #1
2005 STS 4.6L RWD: Has anyone replaced the motor mounts? If so, can it be done without removing the exhaust manifolds? I would be doing this on the garage floor with car on stands. The service manual calls for removing the manifolds but I wondered if anyone has performed this job and if they really had to remove the manifolds. The other question was if someone likes an after market mount better then please offer a suggestion... (I was thinking the aftermarket ones might be smaller and easier to fit back in if the manifolds were left on.)Thanks for your help and suggestions.
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,479 Posts
Didn't do it myself but I remember the mechanic sarcastically saying how much fun my FRT driver side one was to replace....

Think it was over 3 hours worth of labor IIRC.
 

·
Registered
2005 STS Northstar RWD
Joined
·
511 Posts
I think someone on here did it without removing the manifold. Just takes patience. I had a post on mounts a short bit ago that had some good activity. It is on my to do list.
 

·
Registered
2017 XT5, 2010CTS, 2006 STS V
Joined
·
5 Posts
Discussion Starter #4
thanks for your comments. I had searched prior to posting and I did not find much... I think one person said he did it on a lift but I think he was talking about a CTS not an STS.
 

·
Registered
08 STS4 V8 1SG & 04 SRX4 V8 & 01 Monte SS
Joined
·
4,988 Posts
thanks for your comments. I had searched prior to posting and I did not find much... I think one person said he did it on a lift but I think he was talking about a CTS not an STS.
Well the CTS doesn't run with the v8 4.6L so if you can figure out what engine it was it would tell you the car at least to a point.
 

·
Registered
2017 XT5, 2010CTS, 2006 STS V
Joined
·
5 Posts
Discussion Starter #6
To bring closure to this post I did the job over the weekend. The right side is easy, less than an hour. The left side bolts are harder to get to due to the lines, hoses and steering box. I did it without a lift which also made it more difficult.
 

·
Registered
2005 STS Northstar RWD
Joined
·
511 Posts
Thanks for the update and reporting back. So i'm guessing it was doable then. Any tips or pointers, or lessons learned that would help out future DIY'ers?

matt
 

·
Registered
2017 XT5, 2010CTS, 2006 STS V
Joined
·
5 Posts
Discussion Starter #8
Here is my basic description for the next guy who tries this. A lift would be great but I did not have one and made this harder. I also did not want to remove the exhaust manifolds as the service manual suggests...You have to drop the bottom nut off the motor mount then take the mount bracket bolts (4 each out of block) out then remove the mount with the bracket attached on the right side. with the assembly removed from the car take the nut off that holds the mount to the bracket itself, then put the new mount on the bracket. Next put the combined assembly back in position and put the bottom mount nut on and the 4 bracket bolts back in. To get enough room to remove and install the assembly I had to lift the engine up to get the assembly out and in so that means you have to take the bottom mount bolt off the left side too. I also took the transmission mount bolts out so the engine would come up far enough without putting strain on transmission mount. I also took the fan shrould bolts out so the fan would move up enough as I lifted the engine. On the left side the only difference was the bolts are harder to get to. I could not get the mount w bracket assembly out in one piece so I positioned it sideways parallel to the engine so I could take the top mount nut off the bracket and replace the mount as the mount would come out of the area, it is really tight. This was difficult because you have to wedge the bracket while turning the nut. The passenger side takes less than an hour after car is up on stands. The driver side took 2 hours or so. I also had to cut a 15mm wrench off and put a cheater pipe on it to break a few bolts lose. The mount nuts are 13/16 socket and the bracket bolts are 15mm. I had about 180 bucks in parts with a gm discout, but the cadillac dealer parts dept wanted 155 for rt and 130 for the left, The service dept at the caddy dealer wanted 1200 to do the job so I saved 1000 this past Saturday.
Good Luck if you try the right side, the left side is pretty easy though.
I would not recomend this unless you are pretty mechanincal and have done a lot of car repair as it was difficult in my opinion.

Ben
 

·
Registered
2008 sts-v black raven 2004 cts black raven
Joined
·
468 Posts
That's how i did mine minus taking fan out and trans bolts off(i had a lift), didn't take manifold off. It was a pita but i got her done in less time than alldata said. Got rear bushing out without special tool but think tool will help and save time but i have revshift 3 piece bushing now.
 

·
Registered
2005 STS Northstar RWD
Joined
·
511 Posts
So I attempted this one today. And now matter how I tried, the drivers side mount I could not get up high enough to get the stud out of the frame in order to tip the assembly sideways. The bolts are a PITA, but doable, but just couldn't get the assembly or the old mount out. So needless to say the old mount is still in the car, and my efforts were wasted on that side. Also doesn't help being around 110 in the garage today. I think i'm done and may take this in to have someone else complete. I think i've lost 10 lbs of water weight this morning attempting it....
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
From what I hear, you must have AC in your garage. Aren't you seeing 50-year highs in Phoenix?
 

·
Registered
2005 STS Northstar RWD
Joined
·
511 Posts
We have a small portable AC unit that we used in our room before we had our baby so we could cool just our bedroom and not the entire house at night. I moved it to the garage, and the plan was to let it run all night to cool the garage to about 80 or so. Well go figure, that when I go to plug it in it isn't working anymore :( Big part of why I gave up for the day. The heat is miserable. And using the swamp cooler just made it hot and more humid in the garage.
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
Take to it to a reliable shop. I call that money well spent under these conditions.
 

·
Registered
2005 STS Northstar RWD
Joined
·
511 Posts
That's what I was thinking of doing in order to avoid heat stroke. I just don't want the bill lol
 

·
Registered
2008 sts-v black raven 2004 cts black raven
Joined
·
468 Posts
damn thats hot, and dont know why but mine came out. You have to tilt the mount and wiggle that mfer out. Its a pain at first but it will come out if you charm it. I see the oem mounts are wider than these revshift poly mounts so the polys went back in easier.
 

·
Registered
08 STS4 V8 1SG & 04 SRX4 V8 & 01 Monte SS
Joined
·
4,988 Posts
damn thats hot, and dont know why but mine came out. You have to tilt the mount and wiggle that mfer out. Its a pain at first but it will come out if you charm it. I see the oem mounts are wider than these revshift poly mounts so the polys went back in easier.
What are your thoughts about the Rev shift ones?
 

·
Registered
2005 STS Northstar RWD
Joined
·
511 Posts
damn thats hot, and dont know why but mine came out. You have to tilt the mount and wiggle that mfer out. Its a pain at first but it will come out if you charm it. I see the oem mounts are wider than these revshift poly mounts so the polys went back in easier.
I'm going to try and fix the small ac unit I have in the garage and then re-attack this. As some have mentioned, loosening the trans mount may help, also I didn't loosen the other side engine mount, I think that may help too. I'll post back.

The heat is a bitch though. Its suppose to be 113 today :)
 

·
Registered
2008 sts-v black raven 2004 cts black raven
Joined
·
468 Posts
i like the rev shifts @ludacrisvp when i put it in gear it just goes in gear no movement no jerking no vibrations just goes in gear lol. then the rear bushing solved the bucking and banging i did this because im gonna get a tune from madtuner but these freaking furloughs have haunted my checking account lol

----------

and i didnt loosen the pass side when i did drivers side, i was on a lift though, if your on the ground thats the issue
 

·
Registered
2005 STS 1SG
Joined
·
322 Posts
I just did this, basically had the same experience as Ben. Difficult job (no lift, just jacks/jackstands, and really rough ground -- I feel like Indiana Jones after he got dragged under the truck in Raiders, except my adventure took about 6 hours). I'm sore and exhausted but it's done.

I'll post a pic of the bad mount soon. Dealer said they were fine, but this one was GONE (left mount, the hard one). Right side was cracked but still seemed alright, but glad I replaced it.

Be careful because some mounts can fit upside down, I lost an hour to redoing the right side, thank goodness not the left.

Edit - just to document my problem it was heavy vibration at idle and some thunking under power sometimes (probably with loading/unloading engine torque). It's extremely gratifying to find the broken mount. Ride is smooth like new now.
 

·
Registered
2000 Eldorado ETC
Joined
·
25 Posts
Thx for your input, but I have one question. I'm just replacing the FR mount (passenger side), and got the old one out pretty easily. I can't get the new one in, though, as it isn't compressed like the old one. I disconnected both dog bones and the front center mount and lifted the motor as much as I could, but am still 1/4 inch shy of clearance.
What did you have to disconnect to raise the motor enough to get clearance for the new mount?
Thanks in advance!
 
1 - 20 of 22 Posts
Top