Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
Hey all!

2004 CTS (3.6). Half of my 3rd brake light is not lighting up, so I can imagine that one of the lights inside is cooked. Is this a correct assumption? Went to an Autozone to check and see if there was a CHMBL (center high mounted brake light), but nothing showed up. Ended up getting a pair of the same lights used for the brake lights. Lo and behold I look in the manual, and it says it should be replaced at a service center. After poking around on the internet, I found that these can't be replaced individually. Doh! So the entire thing needs to be replaced?

If so, anyone know the part number or how much something like this would cost? Any hookups?

Thanks all!
-Steve
 

·
Registered
2017 XT5 and 2014 Corvette
Joined
·
1,183 Posts
Wrong forum section (this is the Gen II CTS, 2008 and up), but let me try to help you. This isn't gonna be cheap. The MSRP on the CHMBL is $606.96. You can order it from Gene Culley at GMPartsHouse for $473.42. Part link.

 

·
Registered
Joined
·
62 Posts
Discussion Starter #4
Is there anything else this could be if only half of it is on? It does have condensation, and I just realized that it went out around the same time it started logging condensation.
 

·
Registered
'08 CTS
Joined
·
189 Posts
Just make sure to be gentle and follow the directions when replacing the lamp. Otherwise, you risk breaking off one of the plastic clips from the old lamp. I know because this happened to me. Now every time I open and close the trunk I hear that little piece rattling around in the lid and it drives me crazy.

For $650, I replaced all the rear lamps with clear ones. See thread below.

http://www.cadillacforums.com/forum...nd/148490-clear-tail-lamps-pics-included.html
 

·
Registered
2008 Cadillac CTS & 2006 Cadillac STS
Joined
·
41 Posts
Ok guys I have the samer issue my 2008 CTS 3 brake light doesn't work I tested it with the battery and the light works fine
When I test the DC voltage at the connector I get nothing, PLEASE HELP TIA
George Ware
[email protected]
 
1 - 8 of 8 Posts
Top