Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
2011 CTS 3.0 AWD Lux
Joined
·
43 Posts
Discussion Starter #1
Hi,
Dealer replaced water pump and front engine cover seal, all under 40K and still under warranty.
Picked car up and noticed whine or whistle type of noise around 2500 rpm,coming from engine, I think, not related to load or driving conditions., more noticeable when engine is hot.
Of course dealer said it is normal and to stop bother them.
What are my options here?
Thanks
 

·
Registered
2013 CTS Coupe
Joined
·
10 Posts
Hello,
at 2500 RPM any hamster whines. Did you look for a hamster under the hood? :) Sorry, I didn't want to laugh at you, but I couldn't refrain myself.

----------

good luck, sorry again
 

·
Registered
SOLD - 2010 CTS4 Premium Wagon-Diamond White-Cashmere Interior
Joined
·
2,930 Posts
ss4cts,

Look at your invoice and see if they replaced the serpentine belt. I'm wondering if that might the problem (old belt, new settings).

Marv
 

·
Registered
2009 CTS 3.6 LY7
Joined
·
285 Posts
Two things to narrow it down/confirm...
1. When it comes to whether it's the engine or elsewhere in the drivetrain, 'load & driving conditions' isn't definitive. If it's the engine it should make the noise at 2500 sitting in park.
2. Presuming it's the engine the next issue is 'whine' vs. 'whistle' - the former would imply mechanical friction (ex: maybe belt too tight, bad pulley/bearing) the latter perhaps a vacuum leak.

I'd try popping the hood, taking off the cover(s), have a helper hold it at 2500 (in park...) and see if you can narrow down the noise location and whether it's a 'whine' or 'whistle'. If it's in the area the work was performed you can demonstrate to the service person.
 
1 - 4 of 4 Posts
Top