Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Recently I bought a used 2016 Escalade platinum. The instruments panel stars doing weird things. It turns off at the middle of the road (the car on motion) for a second, and come back on. There is no effect on performance of the car. Any one experienced the same thing.
 

·
Registered
Joined
·
37 Posts
Might just be an issue with your battery and voltage. Is it the original OEM battery?

Or I experienced all the same very intermittent symptoms with my previous Escalade, a 2008 model. It was a bad ground/s somewhere that I never actually could locate! So after many troubleshooting experiments and replacing the battery and the negative battery cable ..... I finally solved the issue by running two new additional ground cables directly from the negative connection side of the battery, one to the frame and one to the body. Odd solution but the symptoms completely disappeared and I gave up trying to find the problem connection with everything working fine!!!!
 

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Recently I bought a used 2016 Escalade platinum. The instruments panel stars doing weird things. It turns off at the middle of the road (the car on motion) for a second, and come back on. There is no effect on performance of the car. Any one experienced the same thing.
@CSIMME01
told me about service bulletin #18-NA-161, which Is for positive and/or negative battery cables. Apparently, the cables at the battery will get weak, and not provide enough ohms causing this. I had both of mine replaced at the dealer, and it fixed it.
 
1 - 3 of 3 Posts
Top