Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Discussion Starter #1
I have a 2016 Escalade ESV with 37,000 miles on it. A couple of weeks ago it started shutting down on its own. Completely shutting down gauges and dash completely as if was parked, except with the gear shift in the drive position. Took it to the dealership and after performing a diagnostics scan told me that they could see that there was some sort of anomaly they didn't know what it was nor could they duplicate the incident and gave it back to me. Now both my rear screens don't work, and my Escalade turned off again with me only having back a week from the dealer. Has anyone else had this problem, or know what it may be. Thank you.
 

·
Registered
2016 ESV Platinum
Joined
·
163 Posts
If there is a bad electrical ground it will cause all sorts of strange things to happen. Someone has to go in there and troubleshoot the wiring. I would start checking connections near the battery and the underhood fuses.
 

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Discussion Starter #3
If there is a bad electrical ground it will cause all sorts of strange things to happen. Someone has to go in there and troubleshoot the wiring. I would start checking connections near the battery and the underhood fuses.
The dealer where I took it said that they looked at some harnesses, but didn't say which ones. I will take a look at the areas you mentioned. Thank you.
 

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Discussion Starter #5
Thank you, I will take it back to the dealer and show it to them.
 

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Discussion Starter #6
Thank you CSIMME01, I'll be calling the dealer tomorrow.
 

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Discussion Starter #7
Thank you CSIMME01, they found the positive cable getting hot and losing resistance.
 

·
Registered
2011 CTS4 Coupe, 2014 ELR
Joined
·
311 Posts
Was it the Service Bulletin? Was it the pos battery cable?
Service bulletin #18-NA-161
Is for positive and/or negative battery cables.
I believe jcano took his vehicle to the dealer and mentioned the bulletin. They followed the steps in the bulletin and found a bad battery cable.
 

·
Registered
Joined
·
2 Posts
I have a 2016 Escalade ESV with 37,000 miles on it. A couple of weeks ago it started shutting down on its own. Completely shutting down gauges and dash completely as if was parked, except with the gear shift in the drive position. Took it to the dealership and after performing a diagnostics scan told me that they could see that there was some sort of anomaly they didn't know what it was nor could they duplicate the incident and gave it back to me. Now both my rear screens don't work, and my Escalade turned off again with me only having back a week from the dealer. Has anyone else had this problem, or know what it may be. Thank you.
I needed a new Q screen. Similar issues no Nav no radio and car went black
 

·
Registered
2016 Emerald Green Cadillac Escalade ESV
Joined
·
17 Posts
Discussion Starter #13
I needed a new Q screen. Similar issues no Nav no radio and car went black
The no nav is your GPS antenna. I had mine replaced, and it fixed that. When mine went black it was followed by no start or shutting itself down. Thanks to CSIMME01, Service bulletin #18-NA-161 fixed it. I had both my negative, and positive cables replaced at the dealer.
 
1 - 14 of 14 Posts
Top