Cadillac Owners Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

I bought a 2016 Cadillac ATS on October 15th, 2016, it comes with Apply Carplay. Recently I switched my phone to Android and noticed that the 2016 ATS should also support Android Auto. I called my dealership and Cadillac service, they said I will need to pay extra (about 200-300 CAD) to get the CUE update as it is not mandatory to update.

However based on my research, it seems like others who have 2016 ATS, their dealers either helped them to do the upgrade for free, or the Android Auto is pre-installed. (src: Android Auto in 2016)

When I showed my dealer about this article (Cadillac CUE Update Adds Android Auto), he argued that the article only said Android Auto free update for people buying ATS in 2016 March. However, in my understanding, the website said people who buy the 2016 model before March could receive updates at no charge, and after March it is the dealer's responsibility to update the inventory.

I am very confused now, I thought it is only a software update (since it is already compatible with Apple Carplay). Should this be a free CUE update? Or what is a reasonable price for this to do the Android Auto update?

Thank you very much for helping!
 

·
Registered
2016 ATS4 2.0T and a bunch of other stuff....
Joined
·
857 Posts
I bought my early 2016 used in May 2018. Paid $75 usd for upgrade, dealer said the "complimentary" upgrade was only good during the 2016 model year.
 

·
Registered
Joined
·
4 Posts
I have changed my phone from iPhone 11 pro max to Samsung. No matter what I've tried AA refuses to work on my ATS. Keeps telling me that there is a security issue with the CUE. I have performed the door open reboot no changes. On Star tell me that I should get the dealer to do a "global reset". It is so annoying that the Apple product worked immediately. Any input would be appreciated. I have never liked iPhone but I gave it a year. Glad to go back to the Galaxy.
 

·
Registered
2016 ATS4 2.0T and a bunch of other stuff....
Joined
·
857 Posts
If the AA icon doesn't come up when you plug in your phone it's likely an early build date car that needs the CUE software update to add it.
 

·
Registered
Joined
·
4 Posts
Sadly it is in the CUE menu under apple carplay button. So frustrating but apparently no updates to the phone or CUE make the slightest difference
 

·
Registered
2016 ATS4 2.0T and a bunch of other stuff....
Joined
·
857 Posts
Try a different cord, I've heard it can be an issue.
 
1 - 7 of 7 Posts
Top