Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all, new to the forum. I recently purchased a 2015 Escalade ESV Luxury. When trying to use the automatic lift gate sensor with my foot it wasn't working. I went under the truck and much to my surprise I don't see a sensor, nor do I see a hitch! Per Cadillac specifications both were standard. Per Carfax there was no accident to the rear of the vehicle, and it would have had to been an accident big enough to report to Carfax if the hitch was damaged and and had to be removed.

Has anyone else run into this or have any thoughts? When I made an appointment at the dealer they even asked why I would need one, as it comes standard. I am hoping I didn't by a damaged vehicle without knowing.
 

·
Super Moderator SEMPER PARATUS
2003 DeVille Base
Joined
·
4,486 Posts
Welcome to the forums! Can't answer your direct question, but keep in mind that Carfax is completely voluntary and not a 100% reliable source of history for your Escalade. The info doesn't get there by magic, it has to be reported by a shop/mechanic that voluntarily reports to Carfax.
 

·
Registered
Joined
·
20 Posts
Early 2015's are slightly different from the mid-year 2015i. If you have round emblems and a six speed transmission you have an early 2015. I have an early 2015 and it does not have the automatic rear lift sensor. Not sure when that was added.
 

·
Registered
18 ESV Pemium
Joined
·
62 Posts
What they said on both accounts. My early '15 Denali (loaded) didn't have the wireless charging pad, lane keep assist, tailgate sensor or Android Auto/Apple Car Play......I know I'm missing something else besides the tranny too. Like mentioned, the logo with the wreath is the easiest way to spot the early '15s.

Don't think I've ever seen an Escalade without a hitch. I assume you have the bumper cover for it? If so, you know it's been jacked with.
 
1 - 4 of 4 Posts
Top