Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2015 Cadillac ATS 2.0T
Joined
·
3 Posts
Discussion Starter #1
Any help would be greatly appreciated! My ATS does not have an airbag on the steering wheel, just the cover. My airbag light is always on and always pops up on the display. Also my horn doesn’t work as well as the chirp sound when I go to lock and unlock the car.
I’ve read that those are all symptoms of the clock spring being bad, so I have the part but haven’t installed it yet. I wanted to know if anyone knows if I can get the horn and the alarm chirp to work without having an airbag plugged into the clock spring? If it could be a relay or a fuse could someone help me with locating it? Please and thank you!
 

·
Registered
Prev: 2018 ATS 2.0T NOW: 2020 CT4-V JR
Joined
·
2,536 Posts
While you are waiting for an answer to a very unique problem, make sure the chirp sound is turned on in CUE.
It's an option.
 

·
Registered
2015 Cadillac ATS 2.0T
Joined
·
3 Posts
Discussion Starter #3
While you are waiting for an answer to a very unique problem, make sure the chirp sound is turned on in CUE.
It's an option.
Thank you for the response. Unfortunately my touchscreen has gone out as well so I can’t check to make sure it is turned on, but the new screen is on its way!
 

·
Registered
2013 ATS 3.6L Luxury
Joined
·
337 Posts
Don't know answer to your question, but nyinstaller posted a trick using the CUE when installing a clock spring that might be helpful:

 

·
Registered
2015 Cadillac ATS 2.0T
Joined
·
3 Posts
Discussion Starter #5
UPDATE: Well I went ahead and replaced the clock spring and still no horn, alarm chirp, and still have the airbag light. Airbag was intact, so for that light I’m thinking maybe it’s a different airbag that is the issue? And the horn and chirp issue I’m just gonna replace the $40 horn assembly and if it isn’t that the. I’m guessing it’s a wiring issue.
 

·
Registered
2015 ATS Sedan / 2.0T / RWD / 6-AT
Joined
·
150 Posts
Did you use a voltmeter to check that there is power applied to the horn or not?

Am I right? You do not have an airbag installed?

Had an airbag light issue with the old FIAT of my girlfriend because I removed the drivers seat and deplugged the airbag wire. After the assembly the airbag light stayed on and had to be deleted by OBD-tool because it is an life essential part and light.

Maybe it is a chain reaction that the airbag issue affects the horn.
 
1 - 6 of 6 Posts
Top