Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2014 CTS
Joined
·
4 Posts
Discussion Starter #1
Hello all, I own a 2014 CTS, this is my first Cadillac ever coming from a long history of Infiniti and Nissan ownership. I've owned the car for about 6 months now and recently started experiencing intermittent XM issues.

To explain, when I start the car sometimes after sitting some time, the XM will state the radio ID on the display as normal and then search for signal (car is always parked in the garage, so I anticipate this). However, after receiving a signal and the radio and center display shows the current channel and information, there is still no audio. I can change channels, and the display will change, show what is playing on the channel etc, but still no audio. If I switch to another media source (FM, SD Card, Bluetooth, etc.), there is no issue, the audio and display works in sync; however, if I switch back to XM, still no audio. In addition to no audio, I receive no traffic or weather information either.

Now this doesn't happen all the time and next time I go to the car and start it, sometimes it's fine and there are no issues and radio works as expected. When I got the car, this never happened and has progressively started happening more and more frequently. I know the car is under warranty, blah, blah, blah, but it's inconvenient to have to bring it in and intermittent issues are often the hardest to diagnose.

Anyone else have a similar experience? Solution?
 

·
Registered
NONE
Joined
·
11 Posts
I assume you have a valid trial or paid subscription. You probably have reception problems, either from your car antenna or the feed. Sometimes there are dead (reception) areas but I don't think that's your problem. Start by calling XM for their advice and they'll probably send you a new signal with instructions. If that fails to resolve the problem take it up with your Caddy dealer.
 

·
Registered
2016 XTS Premium
Joined
·
1,782 Posts
Possible bad XM receiver - I had mine changed on my 08 CTS after it finally failed when dealer was present. That issue was XM wouldnt load. But may be related to your problem. If it fails predictively then have dealer present so they can work on it.
 

·
Registered
2014 CTS
Joined
·
4 Posts
Discussion Starter #4
Yes, I have a paid subscription. I'm thinking it's a bad receiver, I guess it's off to the dealership when I get back from traveling; I see leaving it there a few days as the pattern is not very predictable.
 
Joined
·
12,778 Posts
Hi jlewisinsyr,

I’m really sorry to hear about this issue with your XM radio, as I know how much better a car ride is with some good music. I see you plan on heading to your dealership once you finish travelling and I would be happy to open a case file in our system and reach out to the dealership on your behalf when you return. If you are interested in this, please PM me with your VIN, mileage, dealership name, and personal contact information.

Enjoy your day,

Austin J.
Cadillac Customer Care
 
1 - 5 of 5 Posts
Top