Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Originally i had a engine light on for Cam relearn and two misfire codes for P0302 and P0304.
I did the cam relearn with my scanner tool with success and changed coils and spark plugs on Cylinder 2 and 4.
I erased the codes and drove the car for a week and re-scanned with my scan tool and now i just get code P0304
yet the car drive like a top, i feel no misfire at all runs smooth when driving and at idle. What could be causing me to get this misfire on Cylinder 4?
Thanks for your responses in advance, cheers!
Buzzy
 

·
Super Moderator
2014 ELR
Joined
·
10,023 Posts
Move that coil to a different cylinder. Clear codes. Drive car. Wait for code to return. Did the code follow the coil?
 

·
Registered
Go ahead, blame me. Everybody does 🙄
Joined
·
9,493 Posts
Move that coil to a different cylinder. Clear codes. Drive car. Wait for code to return. Did the code follow the coil?
This ^^^
Did you replace the coils & plugs with OEM?
 

·
Registered
2009 CTS4 Premium & 2012 SRX4 Luxury
Joined
·
686 Posts
Something to think about for future troubleshooting, before throwing money at it. How did the old plugs look? Any oil or carbon?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Something to think about for future troubleshooting, before throwing money at it. How did the old plugs look? Any oil or carbon?
I just bought the car from dealer with 110K miles, previous owner put in Champion spark plugs (standard thicker electrode). They looked pretty old, no oil, just electrode part dark & worn a bit all 6 looked the same. Yeah I just wanted to put in OEM plugs. Plus I had a Buick with over 100k and had a plug blow out and had to get a ez out to get the threads out. Wasn't making that mistake again. Especially for the cost of plugs. But yeah i know what you mean, I try to trouble shoot before spending to much money. Cheers!
 
1 - 7 of 7 Posts
Top