Cadillac Owners Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
My 2013 cts coup has been having all sorts of crazy problems the past couple months, started with a service charging systems light then ran through the steps to figuring out what it was with much help from other threads in the forum, i replaced the alternator and it seemed to fix the problem now a month later its having even more issues, i ran into walmart grabbed a couple things and when i got back out to the car i started it and i had a whole dash lit up like a christmas tree, service charging system, service power steering, service break systems, and the stabilitrack was off and i couldnt turn it back on, i went into the trunk and i took the ground off let it sit for a second to reset the computer then hooked it back up and it was all good, fast forward to 11 at night i went to get into my car and my headlights wont work at all, no low beams, no high beams, but it shows that they are on in the car, and my driverside window keeps lowering itself about a qtr of an inch, im completely stumped with this so and help would be highly appreciated
 

· Premium Member
2023 CT5-V RWD / 2020 XT6 Sport / 2024 Lyriq AWD (reserved)
Joined
·
5,433 Posts
I'm still suspecting electrical. Did you replace the alternator with an OEM (Denso) or another brand? Have you checked all grounds? Did you properly clean and torque the positive cable to the alternator? How old is the battery? Has it been bench-tested? Does your car have OEM halogens, OEM xenons or something else?

And...

Do you have a sunroof? Has it rained recently? Finally, how long have you owned the vehicle?

Welcome to CF
 

· Super Moderator
Go ahead, blame me. Everybody does 🙄
Joined
·
18,097 Posts
Welcome to Cadillac Forums, Caz2313--

I'm with NorthernSRX here although the coupe seemed to be unaffected by sunroof issues.

*Load test the battery
*If the alternator wasn't replaced with an OEM part you may have a second failure on your hands.
 
  • Like
Reactions: silversport

· Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Yeah its a reman alternator so it should be oem just rebuilt, i dont have a sunroof either, the headlights are oem no xenon, the battery is 2 years old, and it is decently cold so that may have a role in this but i got it tested and they said it was fine
 

· Premium Member
2023 CT5-V RWD / 2020 XT6 Sport / 2024 Lyriq AWD (reserved)
Joined
·
5,433 Posts
It's the window lowering that has me stumped.

Did you install the alternator yourself or have somebody do it for you?
 

· Super Moderator
Go ahead, blame me. Everybody does 🙄
Joined
·
18,097 Posts
The coupe windows are designed to lower a bit upon opening/closing of the door.
Low voltage may be causing an indexing issue.
 
  • Like
Reactions: Caz2313

· Registered
2009 CTS 3.6L DI Premium, 2014 CTS VSport
Joined
·
3,188 Posts
Yeah its a reman alternator so it should be oem just rebuilt
Unless you retain control of the alternator, like taking your original unit to a competent shop for a rebuild, you have no idea what was installed. Poor quality "rebuilt" or even new alternators from your friendly lowest-bidder parts jockey have an abysmal track record, OEM is the safest bet. You're describing what could easily be another alternator failure, check the voltages vs. load using these notes.
 
  • Like
Reactions: Caz2313
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top