Cadillac Owners Forum banner

1 - 20 of 44 Posts

·
Registered
2013 ATS
Joined
·
2 Posts
Discussion Starter #1
Hello everyone, I'm a long time reader, first time poster. I have been wanting to post this since a long time but never had the time. Every since I had my cadillac (JUNE 2014) I had a rusty moldy AC odor that always comes when I turn my car on. Since June 2014 I have brought my vehicle into the dealer for service on the odor and until now the problem has not been resolved. I am not sure what they do every time they service my vehicle for this problem. I believe all they do is change the filter to mask the odor temporarily. I believe this because, when i pick up my vehicle from service, the odor is not there, however a couple of weeks after the odor comes back. ANY solution to this?


I have read threads on this previously and a lot of people have had this problem. I also read in one thread that some people got compensation for this (I forgot where I found it). Anybody hear about this being an option?

I really hate turning my car on and smelling mold odor from the air coming into the vehicle.
 

·
Registered
2019 XT4 Premium AWD Build 7/22/18 / 2013 ATS4 3.6 Premium Build 12/21/2012
Joined
·
1,622 Posts
Re: 2013 Cadillac ATS

I don't think GM covers pain and suffering compensation. Have you had a sit down with your SA, dealer or contacted GM about it? What does your service receipt say they did to correct it? It sounds like all they do is deodorize it and possibly replace the filter which is intake so it should not make much difference in AC output odor.

If you read the other threads you know there are multiple things they can try e.g. coating, reposition drain,turn on after blower feature. I had my evaporator core replaced completely which fixed it. I understand it was a different part # and they coated it heavily before they installed it. I assume this was the part they use in the 2015. This is a last resort and I would not recommend it because it is so invasive and they tear out the entire dash to get to it. I'm not sure they would even be willing to do it
 

·
Registered
2013 Cadillac ATS 3.6 Performance, White Diamond Tricoat
Joined
·
497 Posts
Re: 2013 Cadillac ATS

I think yours is a pretty common problem, not only with the ATS but with other cars as well. As someone suggested, you can have the after blower feature turned on (that keeps the fan running for a while after the AC is shut off to clear out any condensation) and that might help. Other have suggested spraying something like Lysol in the vents.

If you can't get the dealer to fix it under warranty, I've heard that this works pretty well: http://autogeek.commerce-search.net/search?catalog=autogeek&query=a/c+deodorizer&x=28&y=10 (the first 3 listings in the search).
 

·
Registered
2014 Red Obsession ATS Premium 3.6L
Joined
·
601 Posts
OP, I am guessing u live in hot and humid climate like I do. Its ridiculous GM cant fix a 3 year-old problem. My 14 smells the same. I have been practicing remote starting the car as soon as possible b4 getting in and this has helped my frustration. GM has promised me a fix since 9 months ago. still no word on it yet.

----------

well, it may be a common problem but my civic and acura did not smell like that even though they were old and has got mileage. Its a design flaw and GM has been sitting on it for 3 years with no solution. That is not acceptable.

RocketDawg said:
I think yours is a pretty common problem, not only with the ATS but with other cars as well. As someone suggested, you can have the after blower feature turned on (that keeps the fan running for a while after the AC is shut off to clear out any condensation) and that might help. Other have suggested spraying something like Lysol in the vents. If you can't get the dealer to fix it under warranty, I've heard that this works pretty well: http://autogeek.commerce-search.net/search?catalog=autogeek&query=a%2Fc+deodorizer&x=28&y=10 (the first 3 listings in the search).
 

·
Registered
2014 Red Obsession ATS Premium 3.6L
Joined
·
601 Posts
every summer, we ats owners have to endure both the heat and smell of our ac. ohhh, when will this end?!!!
 

·
Registered
2019 XT4 Premium AWD Build 7/22/18 / 2013 ATS4 3.6 Premium Build 12/21/2012
Joined
·
1,622 Posts
When you sell it, just make sure you sell in the winter.
 

·
Registered
2013 ATS 2.0T Lux, 2017 MB C300 Coupe
Joined
·
997 Posts

·
Registered
2019 XT4 Premium AWD Build 7/22/18 / 2013 ATS4 3.6 Premium Build 12/21/2012
Joined
·
1,622 Posts
Fly I think you and I are the only 2 to get it fixed but we were persistent and our dealers were willing to keep pressing on fixing the problem.
 

·
Registered
2013 ATS 2.0T Lux, 2017 MB C300 Coupe
Joined
·
997 Posts
Fly I think you and I are the only 2 to get it fixed but we were persistent and our dealers were willing to keep pressing on fixing the problem.
I don't know, GJB, I thought that my dealership's (Ed Morse Cadillac, Delray, FL) fix was "approved" by GM. And if this was the case, then I can't understand why other dealerships haven't gotten with the program. I really shouldn't be a matter of "persistence" other than referring your dealership to Ed Morse's approach.
 

·
Registered
2014 Red Obsession ATS Premium 3.6L
Joined
·
601 Posts
yep, fly and gjb, u guys are the only ones that truly got it fixed. most of us either got denied straight up by dealer or it came back after couple of days. 2014ATS3.6AWD said that his dealer is about to implement this bulletin 99-01-39-004F for him. fly and gjb, any of the attempts were done using this bulletin?
 

·
Registered
2013 ATS 2.0T Lux, 2017 MB C300 Coupe
Joined
·
997 Posts
I just went back to check my records. Actually, I had two fixes. The first one was on 11/21/13, in which they did the the "drain" fix. Here's the workorder:



And here is the second fix that I forgot about. This fix seems to be the one that most are getting. Perhaps, one needs to get both.

 

·
Registered
2013 Cadillac ATS 3.6 Performance, White Diamond Tricoat
Joined
·
497 Posts
Mine will end in 18 months when my lease is up!
Apparently it's not restricted to humid climates like mine. You have the moldy smell and live in San Diego, which has idyllic weather. An acquaintance lives in Lake Havasu City (even drier than San Diego) and he has it in his Corvette. But in the heated soup of north Alabama, both my ATS and Corvette are fine. Others who live in humid Florida have it.

Must be something that's not working right in the systems rather than a design flaw or an environmental thing.
 

·
Registered
none
Joined
·
1,102 Posts
Mine comes and goes and i'm in Raleigh NC with 100 degree temps. Humidity hasn't been that horrible but some days are pretty bad.
 

·
Registered
2014 Red Obsession ATS Premium 3.6L
Joined
·
601 Posts
bcoz I am bored... just kiddin A forum member (2014ats3.6awd) who lives in houston pm me saying his dealer is about to perform the above mentioned bulletin to fix his ac smell. so I was wondering if this bulletin has already been tried and if so, what was the results?
DavidATS said:
---------- thanks fly. ur second fix, the replacement of evap core and coil coating is the exact bulletin that 2014ats3.6awd is about to get. he more than likely will also need the drain hose replacment. anxiously waiting for his result.
flycaster said:
I just went back to check my records. Actually, I had two fixes. The first one was on 11/21/13, in which they did the the "drain" fix. Here's the workorder: http://s8.photobucket.com/user/Flycaster1/media/A-C%20Fix%201.jpg.html And here is the second fix that I forgot about. This fix seems to be the one that most are getting. Perhaps, one needs to get both. http://s8.photobucket.com/user/Flycaster1/media/A-C%20Fix%202.jpg.html
 
1 - 20 of 44 Posts
Top