Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Cadillac CTS-V
Joined
·
39 Posts
Discussion Starter #1
Upgraded my 2012 V with the Ligenfelter pully CAI kit in Oct 2012 - worked OK for awhile with great HP gains. Then a few months ago at WOT, the blower started to skip . At lower RPMs no problem. Replaced the fanbelt with a sturdier one,thinking the fanbelt was the problem, but no effect.
The shop that performed the upgrade is trying to get a response and some suggestions from Ligenfelter but no response so far.
Anyone else had this problem ????
 

·
Registered
11v,2 09 v's,2 05 v's,5 GTM supercars,viper,volt,2012 karma
Joined
·
2,997 Posts
What do you mean Skip? As in belt slip noise?
Loss of boost? or Both?

Did you do the P Valve mod?
 

·
Registered
Cadillac CTS-V
Joined
·
39 Posts
Discussion Starter #6
Yeah, skip is not a very good description.
It is a decrease in boost for a fraction of a section repeated frequently at high RPMS . Easily visible on the Caddy boost guage.

Thanks for the referrals to the Pvalve mod. Not sure my guys did that.
When I first had the modification done, it worked like a charm but after 6 months or so , the engine begin the above sketchy performance.
 

·
Registered
2012 Cadillac CTS-V
Joined
·
105 Posts
I think I may have had the same problem you're having. I had new plugs put in and that skipping at high rpms right before its about to shift went away. Its making so much boost that the plugs are probably giving out..
 

·
Registered
09 DW 4DR,AT,Recaros,metco 2.4,RX c-can,AEM-A/F, 634hp,642tq
Joined
·
775 Posts
i'm in the club to, just for reference sake. in the summer no issues (most likely do to bad air quality) but once winter kicked in (cold dense air) the car will buck (lose power/surge) at high rpm in high gear on floored (wot) highway runs. thanks for the input fellow V brethren. I'll contact my tuner when i have the time.
 
1 - 10 of 10 Posts
Top