Cadillac Owners Forum banner

1 - 20 of 36 Posts

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #1
Hey all. I've read several threads on this subject. So I'm pretty sure I know where this is heading, but I thought I'd float the specifics and see what your thoughts are.

I went for a 50 mile round trip drive today. Something I haven't done for about 2 -3 weeks. Otherwise, I make a 5-6 mile trip once a week since the Chinese Virus took over.

On the way home today, the charging System light came on and a few miles later, the Battery Saver message came up. At that point it was running at 11.4 volts. After about 10 miles and upon arrivving home it was hoovering around 11.2-11.3 volts.

I have not done any testing, except to be sure that my Mono-Sub Block Amp was turning off as it should. And it is turning off properly.

I just dropped a new battery in it in December. I doubt its that, but I've seen new batteries turn up bad after a few months, but rarely.

I also dropped a NavTool in it about a month ago, but I doubt that has anything to do with it either.

To my knowledge the charging system is all original. I bought the car 6 years with 27K on it. It now has 88K.

I think its probably the alternator.

As always, your thoughts are appreciated.
 

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #3
I dont trust AutoZone or Advance per se. A better choice is to find someone with a battery Load Tester?????
 

Registered
Go ahead, blame me. Everybody does 馃檮
Joined
9,002 Posts
I dont trust AutoZone or Advance per se. A better choice is to find someone with a battery Load Tester?????
Everyone that reads my posts knows how I despise Walmart. I have a deep seated loathe for that carnival of oddities establishment.
Their automotive department, which I will add is conveniently accessible through a separate door, has a hand held load tester on premises. Call to make sure yours does, too. They tested a battery for me which I double checked with a load tester I had recently purchased and the numbers were spot on with my HH unit.
Or...you can order your own off Amazon like I did. Think I paid around $30.

Bonus: One less trip to Circus of the stores.
 

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #5
I just talked with Batteries Plus, which is where I bought the battery. He told me a way to test the system with an Ohm meter on the battery. You ever hear of that version of testing? He said based on my description of the volts at highway speed, etc. it was the alternator. I said I want to test to be sure.
 

Registered
Go ahead, blame me. Everybody does 馃檮
Joined
9,002 Posts
I'm not saying it's not the alternator, but load testing the battery is the easiest first step.
If it passed, my next step would be testing the alternator.
Can you hear any whining or static in the radio or HVAC?

IIRC, my battery load tester also has a function to test the alternator as well.
 

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #7
i wont have time to really look at it till sunday. I almost always have the stereo cranked. So I dont have any opportunity to hear exterior noise. However, I know I have creakin in the front end!
 

Registered
**2014 CTS4 Sport Wagon-Luxury**
Joined
2,100 Posts
I've heard of testing the way you mention with an ohm meter or using a Multi Meter (chrisFix) but you need to have it checked with a load tester...


I'll repeat a story here about batteries...short version, GF has a car battery for back up on home sump pump system...checked several times and showed no issues...battery back up failed in a storm...I took the car battery (which was 2 weeks old according to the installing plumber and a replacement for the less than 12 month old battery that failed once before it)...it failed the load test at my trusted mechanics...

I replaced that battery with a same size A/C Delco Marine battery (original battery was labeled as a marine battery of the back up companies make) and it has worked perfectly for almost 4 years...

Bill
 

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #10
Bill, if I follow your story, I guess your saying what I said...A relatively new battery can go bad well before its time!
 

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #11
So, I still l haven't had time to dive into this alternator issue. However, I was reading about other member experiences with similar problems. After reading, It could be a bad battery, or a bad alternator, or combination of both, or the ECM. I never quite read about the best place to have a load test done. I don't trust dealerships or AutoZone or Advance. Therefore, the best way is to get your own tester??

On another note, what are thoughts on pulling the OEM alternator and having it rebuilt at a mom and pop shop thats been around for a long time??? If the OEM alternator is rebuilt is it still an OEM alternator????????
 

Registered
Go ahead, blame me. Everybody does 馃檮
Joined
9,002 Posts
So, I still l haven't had time to dive into this alternator issue. However, I was reading about other member experiences with similar problems. After reading, It could be a bad battery, or a bad alternator, or combination of both, or the ECM. I never quite read about the best place to have a load test done. I don't trust dealerships or AutoZone or Advance. Therefore, the best way is to get your own tester??

On another note, what are thoughts on pulling the OEM alternator and having it rebuilt at a mom and pop shop thats been around for a long time??? If the OEM alternator is rebuilt is it still an OEM alternator????????
Walmart for load testing or buy your own tester. It will pay for itself down the road.
I personally would rather have my original alternator rebuilt by a reputable shop vs buying one from Autozone.

You could purchase an OEM unit through RockAuto or a similar source if you can't afford downtime on your coupe waiting for the original to be rebuilt.
 

2011 CTS Coupe Premium
Orlando - We take orphans
Joined
2,502 Posts
I usually rebuild my own alternators, not hard just have to be careful particularly with the brushes.

BTW I have a couple of the schumaker type load devices but one I use the most is an el cheapo BT-360 from e-Bay. Is really accurate about condition. The ones I like now all have plastic clips with a wire in each half and magic happens.
 

Registered
**2014 CTS4 Sport Wagon-Luxury**
Joined
2,100 Posts
Bill, if I follow your story, I guess your saying what I said...A relatively new battery can go bad well before its time!
and that a battery that someone might test and show is fine is in fact not unless a load test was performed...GFs battery tested fine before load test but load test was performed at a local, trusted mechanic...the kind of tester that they roll out on wheels and the test take a little bit of time...showed that "good battery" was dead flat...

good luck with your choice

Bill
 

Registered
2011 CTS Coupe FE3, 2003 Thunderbird, Gone 2013 ATS, 02 Deville
Joined
1,458 Posts
the NEW digital testers can diagnose so much more of what is going on inside the battery than any of that old 1960 equipment.
 

Registered
'14 CTS-V LongRoof; '16 ATS-V Sedan,' 04 Trailblazer 4x4; '10 CTS LongRoof gone but never forgotten
Joined
14,683 Posts
You sound as if you are convinced it's your alternator. Always do the easiest and least expensive fix first. OK, you don't trust Autozombie. In lieu of you buying a tester maybe let them test it and then go to Wally World and have them confirm or deny. Or use your mechanic. One the battery issue is decided then you can go down the alternator rabbit hole.
 

Registered
2012 CTS4 Premium
Joined
159 Posts
Discussion Starter #20
So, the alternator is bad. I'm leaning towards taking it to that local Auto Electric Shop to have it rebuilt.

As I mentioned, I've added a 1200 watt Mono sub block amp and two 10' subs to the audio system. Thats one of the first things I did to this car 5 years ago. Having said that, does the added stereo equipment create a need for a high output alternator?? Is there one for this car? Or can I have him increase the OEM one????? Or is it just not an option or need???
 
1 - 20 of 36 Posts
Top