Cadillac Owners Forum banner
1 - 15 of 15 Posts

· Registered
Joined
·
20 Posts
Discussion Starter · #1 · (Edited by Moderator)
Hey guys, just bought a 2011 cadillac escalade with z95 mangniride suspension. Ended up needing to replace all the suspension as it was riding horribly. Had my local mechanic install new oem rear shocks and new compressor dorman...I ended up putting in the luftmeister front shocks that are oem spec which retain the magneride. Read good reviews on them and for 300 for the set, was willing to take a chance. Cars riding great now!!, but I got the dreaded service suspension light. Ironically when I bought the car all the shocks were shot and pump wasn't even running but no code...go figure. Anyway I got a scanner and isolated to the front left actuator. The code i got is c0575. Any idea how to fix it? My mechanic said the plug was a little wonky when reinstalling? Anyway to just replace plug, or should I just mess around with it, maybe it isn't seated correctly...any help would be much appreciated. My wife is bugging that I spent money on a truck that needs work, but in all honesty, the truck is Mint besides this issue.

By the way I used the obd mx link plus and it was able to pull the suspension codes! In case anybody was wondering.
 

· Registered
It's OK I'm a Limo driver
Joined
·
1,896 Posts
It's either the plug or the shock. I would take the plug off and spray some contact cleaner on the connections and reseat it.
 

· Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
It's either the plug or the shock. I would take the plug off and spray some contact cleaner on the connections and reseat it.
I ended up buying a new sensor plug for the top of the strut just in case, but I will try to clean it as suggested and reseat it before replacing plug. I'll let you guys know how it goes
 

· Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
That's what I figured. Strange thing is with the tpms, the right is drivers side. Odd? I have a bad chrome flaking wheel up front and it has a slow leak, that's what got me questioning left and right with the other code. Really should just upgrade to some 2022 wheels..but my wife will kill me. Just can't justify SPending $300 for one rim that's not oem when I could get a set of takeoffs from a 22' escalade for $1200..maybe even 1k if I can get him down a bit!! Decisions decisions...
 

· Registered
99 ETC 13 XTS 69 Chevelle 17 Yukon
Joined
·
1,460 Posts
That's what I figured. Strange thing is with the tpms, the right is drivers side. Odd? I have a bad chrome flaking wheel up front and it has a slow leak, that's what got me questioning left and right with the other code. Really should just upgrade to some 2022 wheels..but my wife will kill me. Just can't justify SPending $300 for one rim that's not oem when I could get a set of takeoffs from a 22' escalade for $1200..maybe even 1k if I can get him down a bit!! Decisions decisions...
You just need to have tire pressure monitors reset for where they are located someone probably rotated tires.
 

· Registered
Joined
·
20 Posts
Discussion Starter · #8 ·
It worked.. replaced the sensor connection at top of strut and code is gone..hallelujah. whole new suspension with labor for $1200. Oem in back, luftmeisters upfront retaining full magneride and air rears.
 

· 2009 Escalade
Joined
·
2,195 Posts
This was nice seeing a service suspension code thread from start to totally cured. As far as rims go, if you’re in a state that’s EPA friendly re-chrome is an option. Some marine and coating shops have the skill to powder coat over the OE chrome finish.

Regardless of what you find, powder coat with another coat of clear powder coating will provide a finish that looks wet and new for over a decade. When applied by a pro it’s literally impervious to anything the road. I’ve used it on calipers because I hate cleaning and repainting them.

This is a rear aluminum caliper pulled from an Audi TT for the rear of my 90 Corrado g60. It was sand blasted, powder coated, then clear powder coated when disassembled, then rebuilt with all new components.




Sent from my iPhone using Tapatalk Pro
 

· Registered
99 ETC 13 XTS 69 Chevelle 17 Yukon
Joined
·
1,460 Posts
This was nice seeing a service suspension code thread from start to totally cured. As far as rims go, if you’re in a state that’s EPA friendly re-chrome is an option. Some marine and coating shops have the skill to powder coat over the OE chrome finish.

Regardless of what you find, powder coat with another coat of clear powder coating will provide a finish that looks wet and new for over a decade. When applied by a pro it’s literally impervious to anything the road. I’ve used it on calipers because I hate cleaning and repainting them.

This is a rear aluminum caliper pulled from an Audi TT for the rear of my 90 Corrado g60. It was sand blasted, powder coated, then clear powder coated when disassembled, then rebuilt with all new components.




Sent from my iPhone using Tapatalk Pro
That really looks nice.
 

· Registered
Joined
·
20 Posts
Discussion Starter · #13 ·
Unfortunately I called a couple rim shops and they won't touch these. Apparently in jersey it is not allowed. Working on getting a great deal on Craigslist for a new 2022 takeoff wheels chrome for 1000$. Then I'll just mount the tires I have since they still got life in them!
 

· 2009 Escalade
Joined
·
2,195 Posts
It’s definitely hit n miss on shops willing to resto these. I know our trash company has its vehicles polished and chromed so well they make fire engines look like a base models. I’ll have to check with them.

Good call on late model rims. It males it 200x easier to locate a replacement if you damage one. Try and get a sample or at least a picture of what your new lugs will look like. The existing lugs may not work due to length or lug face design.


Sent from my iPhone using Tapatalk Pro
 

· Registered
Joined
·
1 Posts
It worked.. replaced the sensor connection at top of strut and code is gone..hallelujah. whole new suspension with labor for $1200. Oem in back, luftmeisters upfront retaining full magneride and air rears.
Do u have a part number for the sensor u replaced? I'm having the same issue but can't find the part anywhere online it just shows pictures of the ride height sensors when I try search for it
 
1 - 15 of 15 Posts
Top