Cadillac Owners Forum banner

1 - 20 of 30 Posts

·
Registered
2015 SRX4 Luxury
Joined
·
621 Posts
Discussion Starter #1
So, my dealership just had my SRX for a week to replace the timing chains. I also asked them to check for a loud noise when turning the steering wheel in this cold weather. Technician drove the car and said it's ready to
go. They could not replicate the steering noise problem.

I get in the car to leave and before I get out of the parking lot I notice a noise like and exhaust leak. Hit the highway and it is LOUD with poor acceleration. Turn around and take the technician for a quick drive. The steering noise is quite obvious so the tech says "yeah, that's the strut bushings, very common, I'll get those ordered for you" (mind you he just drove it and couldn't replicate it). Again, I'm not even out of the parking lot and the "exhaust" noise is quite noticeable. He says "sounds like an exhaust leak but I didn't touch the exhaust. Drive it this weekend and see if it goes away". OKAY. Now the next day and the SRX is running VERY rough (almost
dying at idle and sounds like an old hoopty) and the service engine and stabilitrak lights are on. The turbo gauge keeps dropping to nothing under acceleration and there is a weird noise down by my feet. I hope I can make it to the dealership Monday morning.

I'm not really bitching yet but does anyone know what the tech could have messed up to make the engine so much worse after new timing chains?? If he messed something up even worse (like the turbo) will they still fix
all this under warranty? This is the third major issue with the SRX and I hope I didn't buy a lemon but this makes me think maybe the local Cadillac Techs just aren't up to par!!

Anyone else had the timing chains replaced on a turbo SRX?

Thanks, Chris
 

·
Registered
2016 SRX Performance, 2006 STS 4,
Joined
·
234 Posts
Oddly enough last night I had the same problem with my turbo. It was working strong the cut out, and the car went into limp mode , restarted the car and it was fine, but if I did wot, the turbo would cut out and goto limp mode. Cel is on and a po234, . off to the dealer this week for fix
 

·
Registered
2015 SRX4 Luxury
Joined
·
621 Posts
Discussion Starter #4
I can't even keep mine running now. Idle is VERY rough and LOUD, almost like the exhaust is leaking...all the warning lights are coming on. Needless to say, I am not very happy right now!! Just got 8 inches of snow and it is still coming down
and my only AWD vehicle is down after just spending a week at the dealer!!
 

·
Registered
2016 SRX Performance, 2006 STS 4,
Joined
·
234 Posts
I feel you, I bought mine in October and it has been in the dealer in and out since then, my last visit which was last week it was there for 2 weeks. When car runs good it the best! I was telling everyone how great the car was finally after all the repairs. Went to start it after dinner had the service theft deterrent system, car wouldn't start , called onstar and they told me they would send road service. I pulled the. Key out of the remote And unlock my door and then the car Started.

Guess I spoke too soon, when I said all fixed!
 

·
Registered
2015 SRX4 Luxury
Joined
·
621 Posts
Discussion Starter #6
Well, she has been at the dealership all week and I had to call for an update again! Anyway, they found a bad gasket hence the air leak I heard and replaced the front strut mounts due to noise in cold weather. Hope to pick her up tomorrow....let you know what gasket needed replaced as it was just fine before they replaced the timing chains...they did give me a 2011 CTS4 as a loaner but it just doesn't compare to the SRX4 premium!! Forgot to mention I found a vacuum hose in the back of the engine that had come loose...hence the rough idle.
 

·
Registered
2015 SRX4 Luxury
Joined
·
621 Posts
Discussion Starter #7 (Edited)
UPDATE!
Over 2 weeks at the dealership now waiting on a gasket. Found bad gasket and air leak. I also told them I found a bad vacuum hose that was replaced along with the o-ring and a valve. Funny how it was running perfect before I took it in for a service engine light. All this because they replaced the timing chains (known issue??). Anyway, driving home tonight and when I hit the gas over 40 mph there is a horrible squealing noise / air leak sound and the turbo gauge is dropping to zero again!!! I swear they don't test drive their vehicles after they work on them!!! Even after I requested it TWICE!! I guess I will call tomorrow and leave it there for another week.
My patience has run out!! Forgot to mention the service stabilitrac light keeps coming on now as well....related???
 

·
Registered
2010 SRX 2.8T
Joined
·
24 Posts
I am going through the same issue. I am loosing boost getting a fault code P0299. Car has been in the shop for a week now. The dealer has no Idea what it is so now they have GM head office involved. I have been going through this for a year now car has been in the shop 20 times for turbo issues. Low boost then to much boost. I am running out of patience and now loosing time out of my day trying to figure out what it can be. The turbo was replaced twice then the waist gate was replaced then they found a loose turbo inlet pipe that didn't even fix it. Hopefully someone can help me get this issue resolved. I honestly think these techs are just not familiar with turbo engines. Not sure if I should take the car to a Saab tech!!
 

·
Registered
2010 SRX 2.8T
Joined
·
18 Posts
OK...I HAVE THE SAME CRAPPY CAR AS ALL OF YOU. Less than a year ago the turbo has been replaced, the exhaust Y pipe has been replaced, waste gate issue supposedly solved. AND NOW, no acceleration, engine screams up to 5500 rpm and no passing ability, running like it's being choked to death! WHEN WILL THIS STOP!!! Why can't we all get some sort of compensation to ditch these CRAPPY SAAB TURBO ENGINES and get a decent GM engine in the same model, like the 3.0 or the 3.6. These 2.8T engines are LEMONS!! I am so dissatisfied with CADILLAC on this issue, I'm not sure I even want to trust them anymore. They have always been the "high end" automobile and you definitely pay the price for the DAMN logo, but they do not stand behind a buyer even tho they know this is an issue with EVERY one of these engines. I am now at the very end of my extended warranty and I'm sure MPP won't want to pay to repair it AGAIN even tho they sent this same dealer who repaired it last time a remanufactured "guaranteed" turbo with a year warranty. I haven't heard back from the dealer, but I AM SO FED UP WITH THIS CAR & CADILLAC AT THIS POINT, I MAY NEVER BUY ANOTHER ONE AGAIN.
 

·
Registered
2011 SRX Turbo
Joined
·
4 Posts
My 2011 Turbo SRX is definitely a lemon, although I absolutely love how it looks. It is in the shop now with turbo problems. 3 of the 6 cylinders blew right after I bought it used 4 months ago. Once I got it back (after 3 months) it only lasted a day and started to overheat again, I was told it was related to the turbo and that may have been what caused it to blow the cylinders originally. I will keep you posted on what they found out.

~Teresa

----------

Oh No!!! That is awful, I am a realtor and was so excited to have such a gorgeous car! I had it only 30 days and it blew the motor and was told I needed a new engine! Now they are saying it is all related to the turbo. I love Cadillac too, I do not want a different car but I have been reading terrible things about the 2010 and mine is 2011 but I bet has 2010 issues. I feel your pain!!!!!! I have this gorgeous car that has been in the shop 3 MONTHS!
 

·
Registered
2010 SRX 2.8T
Joined
·
18 Posts
No only have I had all the timing chains replaced, I have had every component of the turbo changed to new parts and I am still getting a P0299 code. WHY?????? The "professionals" at Frank Kent Cadillac in Corsicana, TX, said that it has to be the catalytic converter that has failed. REALLY??? I went to a professional muffler shop and according to the codes he read off my car, none were the right codes for the cat. Those codes are P0420 & P0430. SO WHO THE HELL KNOWS WHAT THEY ARE TALKING ABOUT?? I WANNA KNOW!! If you can't trust a so-called "professional" Cadillac dealership mechanic (that you've paid lots of money to correct the problem) then who the hell can you trust to actually fix the problem? They said they even worked with a GM professional over the phone and still cannot GET IT RIGHT! I think I'll have to call GM myself and ream them out about the crappy 2.8 turbo they installed in 2010 and 2011 SRX's. Do you ever wonder why they didn't keep installing them after those 2 years? The answer is "THEY ARE JUNK SAAB TURBO'S" and GM will not back up their customers even tho they created the crappy engine.:banghead::annoyed::mad2::tisk::rant2::kick::gun2::gun::wtf::ripped:
 

·
2014 SRX Performance FWD
2014 SRX Performance FWD
Joined
·
179 Posts
"THEY ARE JUNK SAAB TURBO'S" ?? -- I put 280k miles on a Saab turbo 6 cylinder......
 

·
Registered
2012 SRX Luxury
Joined
·
395 Posts
Sorry, but in the SRX they are "junk SAAB turbos" lol

Maybe in a real designed in application like SAAB had it was good. They just goofed up on this one trying to save money on design costs probably.

Steve
 

·
2014 SRX Performance FWD
2014 SRX Performance FWD
Joined
·
179 Posts
Sorry, but in the SRX they are "junk SAAB turbos" lol

Maybe in a real designed in application like SAAB had it was good. They just goofed up on this one trying to save money on design costs probably.

Steve
Saab doesn't make turbos anyway....Garrett, Mitsubishi, etc...
 

·
Registered
2010 SRX 2.8T
Joined
·
18 Posts
Lucky for you...have you even read this full thread??? Nothing but problems from other owners just like me, not you. We are trying to find solutions, not people bragging. Sorry, fella!
 

·
Registered
2010 SRX 2.8T
Joined
·
18 Posts
They are the same exact turbo that went in a SAAB that GM attempted to use in the 2010 & 2011 2.8L turbo SRX's...I know what I'm talking about, sir. I know the "actual" turbo doesn't have a SAAB nameplate on it. This is not about SAAB's per se, but the terrible idea someone who makes millions of dollars a year designing Cadillacs that has me and many, many other frustrated and BROKE!
 

·
Registered
2009 CTS4 Premium & 2012 SRX4 Luxury
Joined
·
638 Posts
There is info out there about the potential for problems due to the way some of the SRX turbo were programmed to handle different octane fuel. Owners were blowing their engines driving aggressively with low octane fuel. There was a recall I believe to correct, but if you bought a used vehicle, who knows if the reprogramming was done or how the previous owner drove or what octane gas they used regularly. Have you been using premium fuel as recommended?

And sorry but I had to LOL at someone wishing for a "decent GM engine" like the 3.0 or 3.6 when there's other threads here from 3.0 and 3.6 owners cursing GM for their timing chain problems.
 

·
Registered
2010 SRX 2.8T
Joined
·
18 Posts
There is info out there about the potential for problems due to the way some of the SRX turbo were programmed to handle different octane fuel. Owners were blowing their engines driving aggressively with low octane fuel. There was a recall I believe to correct, but if you bought a used vehicle, who knows if the reprogramming was done or how the previous owner drove or what octane gas they used regularly. Have you been using premium fuel as recommended?

And sorry but I had to LOL at someone wishing for a "decent GM engine" like the 3.0 or 3.6 when there's other threads here from 3.0 and 3.6 owners cursing GM for their timing chain problems.
LOL. I use premium fuel. It is written on the inside of my gas tank lid. I have never put even a mid-grade fuel in it. My 2010 SRX 2.8 also had a timing chain problem, but they are only a year old now. I received the code of P0008 (timing chains problem) not long after I bought it used. I had my local GM dealer run an inquiry on what all was done to it since the original purchase and it was not one that had to have the engine replaced due to the octane problems. Mine was manufactured with the warning on the gas lid with the high octane use only. I cannot drive this vehicle hard at all because it won't allow it. But, thank you for the info. It will be useful for others in this thread.
 

·
Registered
Joined
·
1 Posts
2010 SRX TURBO issues. Had the car 2 years in May. No engine issues until July, when suddenly a loud noise under hood, slowed acceleration, ESPECIALLY with the A/C on. Sounds like a loud helicopter. Code indicated engine underboost and mass air flow sensor, which was replaced 2 months ago. Took the car to a GM shopit was diagnosed as a bad turbo. In shop a month, picked it up, same issue. Turbo indicator goes next to the red with every acceleration. Never happened previously. Wanted to get a new Caddy, LOVE my SRX. But this is maddening. They KNOW these engines were troubled. They pulled them immediately after a year. Why won't Cadillac make us whole? This just makes no sense. There are SO MANY reports of these problems.
 
1 - 20 of 30 Posts
Top