Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2002 Deville sls
Joined
·
4 Posts
Discussion Starter #1
I replaced the water pump what a pain.1.5 days. Now the pump works great and the engine runs fine no leaks, Now the car shifter moves but the light on the dash showing what gear you are in stays in park and the car will not move forward or reverse. I ran the scanner and show no codes. I have rechecked all connections I can see and i am at a loss for an answer. The car drove into the garage just fine before the repair. What have I not done or done. It is terribly depressing to not work after such a difficult repair for me. HELP!
 

·
Registered
2002 Deville sls
Joined
·
4 Posts
Discussion Starter #2
I replaced the water pump what a pain.1.5 days. Now the pump works great and the engine runs fine no leaks, Now the car shifter moves but the light on the dash showing what gear you are in stays in park and the car will not move forward or reverse. I ran the scanner and show no codes. I have rechecked all connections I can see and i am at a loss for an answer. The car drove into the garage just fine before the repair. What have I not done or done. It is terribly depressing to not work after such a difficult repair for me. HELP!
This is on a 2010 DTS
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,074 Posts
Check the shift cable ball socket on top of the transmission - in the engine compartment, at the firewall, about where your gas pedal toes would point.

Otherwise, maybe a failed Internal Mode Switch (IMS)

4T80E solenoids and sensors.gif
 

·
2006 DTS perf
2006 DTS Performance Lux III
Joined
·
1,046 Posts
Yes check the cable. It's on the same side as the water pump.You somehow disconnected it.
 

·
Registered
1968 Deville convertible
Joined
·
115 Posts
Like others have said you probably disconnected the cable. I just did the water pump yesterday I didn't think it was that bad. When you went to remove the egr or get to those 2 bolts on the bottom of the crossover pipe that are closer to the firewall the shift cable is right there. Here is a tip if you have to get back in there next time don't leave the car in P put it in the lowest gear of 1. This moves the cables out of the way and you can get those bolts very easily and remove them a whole turn at a time with a ratcheting open-end wrench instead of 1/4 turn at a time.
 
1 - 5 of 5 Posts
Top