Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited by Moderator)
I have a 2009 escalade hybrid and i cant figure this check engine code p0481 cooling fan relay 2. Ive tried new relays (all 3) and also replaced the 2 cooling fan resistors located on radiator/fan shroud. Code triggers immediately after clearing codes. The right fan runs on high speed and super loud as soon as car starts, even with a/c off. Car temps usually at driving sits around 199-205f, but when im going up hill it hits 220-230f. Left fan does not turn on at all. Once key is turned off, fan shuts off. No matter the temp. Anyone know the problem or has had this issue? Please help... cant find anything on the web and this discussion is the closest ive found so far after months of searching.

Moderator edit: Identical post merged into this thread started by the OP. Sub.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I have a 2009 escalade hybrid and i cant figure this check engine code p0481 cooling fan relay 2. Ive tried new relays (all 3) and also replaced the 2 cooling fan resistors located on radiator/fan shroud. Code triggers immediately after clearing codes. The right fan runs on high speed and super loud as soon as car starts, even with a/c off. Car temps usually at driving sits around 199-205f, but when im going up hill it hits 220-230f. Left fan does not turn on at all. Once key is turned off, fan shuts off. No matter the temp. Anyone know the problem or has had this issue? Please help... cant find anything on the web and im hoping someome here has experienced the same issue and has found a fix.
 
Joined
·
12,816 Posts
I have a 2009 escalade hybrid and i cant figure this check engine code p0481 cooling fan relay 2. Ive tried new relays (all 3) and also replaced the 2 cooling fan resistors located on radiator/fan shroud. Code triggers immediately after clearing codes. The right fan runs on high speed and super loud as soon as car starts, even with a/c off. Car temps usually at driving sits around 199-205f, but when im going up hill it hits 220-230f. Left fan does not turn on at all. Once key is turned off, fan shuts off. No matter the temp. Anyone know the problem or has had this issue? Please help... cant find anything on the web and im hoping someome here has experienced the same issue and has found a fix.
We are sorry to hear these frustrations. So we may look into this further, we kindly ask you to send an email to [email protected], ATTN: Sneakyx16 / Cadillac Forum. Please include your full contact information, VIN, current mileage and the name of your servicing dealership. We will be looking out for your response.

To learn more about GM's privacy policy, please visit Privacy Statement | General Motors.
 
1 - 3 of 3 Posts
Top