Cadillac Owners Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
2009 cadillac escalade awd.

Everytime I start truck and put it in drive I get a stabilatrack light but I take off about 5-10 mph and my driver wheel brake locks up on me....last about 5-10 seconds and releases and won't happen again till I turn truck off and restart it over again. I ended up changing the caliper with a used one and took it to brake check to get all new brake fluid in the system and still causing the caliper to lock up and suggestions or anyone had this problem and also have no abs lights or warning on screen about brakes. TIA
 

·
Registered
1984 Fleetwood Brougham Coupe, 1999 ETC, 2012 ESV Premium
Joined
·
172 Posts
Have the codes read, it may be more explanatory. Let us know what those codes are.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Ok will be doing it tom. For sure I will get back by tom. With codes
 

·
Registered
2008 Escalade ESV, 2011 Indian Chief Blackhawk
Joined
·
9 Posts
Pull both front antilock hub sensors and check for debris/corrosion. Rust and mud can foul the sensor lens and cause erroneous braking action.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Well driver side has new wheel bearing and sensor but when I bought the wheel bearing was really hard to spin and this was straight out the box is it supposed to be like that
 

·
Registered
1984 Fleetwood Brougham Coupe, 1999 ETC, 2012 ESV Premium
Joined
·
172 Posts
Well driver side has new wheel bearing and sensor but when I bought the wheel bearing was really hard to spin and this was straight out the box is it supposed to be like that
It's brand new and packed with grease, it should be hard to spin.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
well got my escalade scan and got for a bad TCM shop said to replace wiring inside trans and sensors so i have my appointment tom. I will let yah know if that fixes my traction light..was the only problem on truck and my parking assist module.
 

·
Registered
1984 Fleetwood Brougham Coupe, 1999 ETC, 2012 ESV Premium
Joined
·
172 Posts
well got my escalade scan and got for a bad TCM shop said to replace wiring inside trans and sensors so i have my appointment tom. I will let yah know if that fixes my traction light..was the only problem on truck and my parking assist module.
Fingers crossed.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #10
Made my truck a lot better with fresh tyranny fluid and filter and harness replaced but doesn't get rid of the locking up issue..ended up being that its not my brakes its my hub bearing but what I dont understand is the hub is new could it be broken?
 

·
Registered
2014 ELR
Joined
·
224 Posts
I think your problem may be a bad yaw rate signal. It could be causing the wheel lock up. The sensor might be bad or there could be a wiring issue. You woukd need to use a good scan tool that can show you data from the ABS module.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #14
Do you
I think your problem may be a bad yaw rate signal. It could be causing the wheel lock up. The sensor might be bad or there could be a wiring issue. You woukd need to use a good scan tool that can show you data from the ABS module.

Happen to know where the yaw rate sensor is located
 
1 - 16 of 16 Posts
Top