Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2008 SRX and 1997 DeVille
Joined
·
1 Posts
Discussion Starter #1
Brake light works, turn signal works, just running light not working. How do I fix?:bigroll:
 

·
Registered
06 v6 SRX
Joined
·
491 Posts
Oh ! This is the part your going to Love about GM . You have to replace the complete tail light ! And here is the real kick to the groin , Its $750. and about an hour to replace . Or you could have the Stealership replace for $1200.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
There is a separate fuse in the left rear fuse block for the right rear lamp. There may also be a 'B' DTC.
 

·
Registered
2008 SRX Sport Pkg
Joined
·
1,135 Posts
Why would you need to replace the complete tail light? Are you saying that the bulb is embedded into the LED unit? If that was the case and it was me, I would find a way to mount a new lamp inside the unit. The LED units cost a small fortune.
 

·
Registered
SRX 2008, SRX 2013,
Joined
·
1 Posts
Hey DAG101,

I have the exact same issue with my 2008 srx. Can you fill me in on how you fixed this issue? I figured out that my taillight was actually good. It seems to be either a fuse, wiring, or a faulty module. I have the entire car pulled apart so any help from a fellow SRX buddy is greatly appreciated.

Thanks again!!!
 

·
Registered
'07 - 3.6l SRX RWD, '16 - 2.5l Subaru Outback, '95 - 4.3l S10 pu
Joined
·
957 Posts
I vaguely recall a discussion where tail light issues was traced to a broken wire in the transition from the liftgate to the body. A bunch of wires go thru the accordion tubes that you'll see at the top of the liftgate. Over time the flex from opening and closing causes a wire to break. You might try flexing the tubes to see if the faulty lights come on. I had this happen on a GMC Envoy. Fix was a matter of soldering the wires back together. May not solve your problem but cheap to try.
 
1 - 6 of 6 Posts
Top