Cadillac Owners Forum banner

21 - 38 of 38 Posts

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #21
Can't you reset it like you do the oil? I just went to look at mine and the transformation life isn't even there. I could of swore it was. here is what a tech 2 can do. basically everything but drive the car. Its big and bulky and is oldschool but its works. I have the clone even comes with the GM stickers. IMO GM buys these than say it's theirs and charges 2k for them but I haven't researched for that to be a fact or not but that is just my opinion.

Nope.Not in there. I am going to call Caddy up here before I shell out 150 for a Tech 2.Thanks for the info.
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #22
So i went on ALLTECH here at work and read thru the 08 Caddy tranny fluid process and at the end it said....RESET OIL LIFE to 100%!! That makes no sense.
 

·
2006 DTS perf
2006 DTS Performance Lux III
Joined
·
961 Posts
So i went on ALLTECH here at work and read thru the 08 Caddy tranny fluid process and at the end it said....RESET OIL LIFE to 100%!! That makes no sense.
That means the transmission oil life. Reset it back to 100% and you're all set.
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #25 (Edited)
Resetting the engine oil life monitor does nothing. I didn't think it would but I took a shot. Still says tranny life exceeded. Absolutely nothing about how to reset in the manual. Caddy dealer is no help.
 

·
2006 DTS perf
2006 DTS Performance Lux III
Joined
·
961 Posts
Resetting the engine oil life monitor does nothing. I didn't think it would but I took a shot. Still says tranny life exceeded. Absolutely nothing about how to reset in the manual. Caddy dealer is no help.
I misunderstood your post. Resetting the oil life monitor doesn't reset the trans monitor. The trans monitor has to be reset by a tech 2 or equivalent. I reset mine and my neighbors who has a 2010 DTS.
 

·
Registered
2008 DTS Platinum. gone: 04 Deville, 76 Eldo conv, 74 Fltwd
Joined
·
199 Posts
I have the same driver's side cold air instead of hot after about 15 minutes. Sometimes it resets when I restart the car. I've taped over the air vents. Getting to the actuator on the driver's side looks pretty difficult.
 

·
Registered
'93 SedanDeville 60 Special
Joined
·
198 Posts
Yes.P0411-AIR INJECTION SYSTEM-Incorrect air flow detected.
Off of each exhaust manifold is as AIR check valve which allows the air moving through from the AIR pump
they tend to freeze up due to heat of exhaust.

1 or both could be stuck so that air is not getting injected into exhaust of both head sides and past front O2 sensor(s) and they then report a imbalanced AFR

You can try first to take them off and soak them in a cleaner
If working you can blow air in one direction OK but not flow when blowing from the other side.

Best is using a OBD-II scanner and see if fuel trims and B1/S1 O2s look balanced values.
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #33
Off of each exhaust manifold is as AIR check valve which allows the air moving through from the AIR pump
they tend to freeze up due to heat of exhaust.

1 or both could be stuck so that air is not getting injected into exhaust of both head sides and past front O2 sensor(s) and they then report a imbalanced AFR

You can try first to take them off and soak them in a cleaner
If working you can blow air in one direction OK but not flow when blowing from the other side.

Best is using a OBD-II scanner and see if fuel trims and B1/S1 O2s look balanced values.
Thanks!
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #34
I have the same driver's side cold air instead of hot after about 15 minutes. Sometimes it resets when I restart the car. I've taped over the air vents. Getting to the actuator on the driver's side looks pretty difficult.
Taping over helps?? Does it force air out the other side or something?
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #35
This friggin A.I.R THING IS A ROYAL PAIN THE THE RUMP. Had somebody blow out that tube connected to it and the same codes keep coming back. secondary air blah blah.
 

·
Registered
2008 DTS Platinum. gone: 04 Deville, 76 Eldo conv, 74 Fltwd
Joined
·
199 Posts
Taping the 4 (!) driver footwell vents stops the cold blast on my lower legs. On our annual winter trip to Connecticut, I wear a second pair of socks. I replaced the exterior and interior temperature sensors and the main dash control with no improvement. The actuator must have a mind of its own.
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #37
Taping the 4 (!) driver footwell vents stops the cold blast on my lower legs. On our annual winter trip to Connecticut, I wear a second pair of socks. I replaced the exterior and interior temperature sensors and the main dash control with no improvement. The actuator must have a mind of its own.
I'll give the tape a try until I can get the actuator installed.Thanks
 

·
2008 DTS
Joined
·
99 Posts
Discussion Starter #38
Well,I finally got the a.i.r to set.I had to take a couple of 200+ mile trips last week and that did it. I did recall seeing something online when I googled the problem and one of the things they said to do was take a 300 mile trip for it to reset..and that worked. Although I did see that p0411 pending a couple of times during the ride while hooked to the scanner. Car passed inspection. Had to have the inner/ outer tied rods replaced and a new serpentine belt put in to pass,but no CEL.HAD THE REAR VALVE COVER GASKET REPLACED TOO. Took a while but they got it done. I'm wondering if those bad tie rods is what caused he wheel to shake coming down off high speed on the highway. I thought it was the rotors but they looked ok. Thank GOD I had an extended warranty that covered most of that work to the tune of 900 bucks.Thanks for all the info people. Appreciate it.
 
21 - 38 of 38 Posts
Top