Cadillac Owners Forum banner

1 - 20 of 38 Posts

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #1
When the heat/defrost etc is on,it's warm-hot on the passenger side and cool on my side. Is that the blend door?/If so,what's the fix??Couldn't find anything worthwhile on youtube. Also,the CEL came back on after replacing the A.I.R. and the gas filter pressure thing last week.
 

·
Registered
Alexandra - 96 SDV Clyde - 15 Silvy
Joined
·
6,357 Posts
For the HVAC issue, that does sound like a sticky blend door. Best bet is a new part. As for replacing it, an alldata subscription may help, not sure if anyone has gone that in depth on these cars.

Was the AIR pump you put in a brand new part? How did the electrical connector look?
 

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #5
For the HVAC issue, that does sound like a sticky blend door. Best bet is a new part. As for replacing it, an alldata subscription may help, not sure if anyone has gone that in depth on these cars.

Was the AIR pump you put in a brand new part? How did the electrical connector look?
It was.I don't know because had someone put it in.I have since had a new pump put in.Got the car back last night so we'll see if that did the trick. Also had new plugs and tranny fluid put in.I never knew that old tranny fluid status can picked up on a scanner I have.It said the fluid was pretty much dead. Next will be new valve cover gaskets and oil pan gasket.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
67,179 Posts
Your car has both engine AND transmission oil life monitor system(s). Owner's manual.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
67,179 Posts
It's a normal DIC message readout. You can reset them yourself, in the car, no scanner. DIC control buttons - BUT search the owner's manual for OLM info. Things may have changed with the death of Deville in 2005.

An engine OLM reset is done at each oil change - and you can bet the dealership or Oil Doodle doesn't hook up a Tech-II to do it.


 

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #10
It's a normal DIC message readout. You can reset them yourself, in the car, no scanner. DIC control buttons - BUT search the owner's manual for OLM info. Things may have changed with the death of Deville in 2005.

An engine OLM reset is done at each oil change - and you can bet the dealership or Oil Doodle doesn't hook up a Tech-II to do it.


I looked for the transmission reset like the oil life reset and there isn't one that I've seen in my 08. I hooked up my scanner and tried to clear it and it's not clearing that way. I;ll just drive it and hope it resets itself after a while.
 

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #11
I had the same code, heres the link to my thread and troubleshooting. https://www.cadillacforums.com/threads/p-0411-dts-exhaust-leak-before-catalytic-converter.1081088/page-2#post-17717316 Not to say you should throw a part at it, but for around 50 dollars you can get a air pump, and the install isn't to bad.
I bought a new pump and had a guy installed it....after buying another new part for it that wasn't the pump. Got the car back the other day and drove it today for the first time since then.The light stayed off for a couple days and came back on tonight.I used my remote start like 4 or 5 times today,if that has anything to do with it. I cleared the codes again!Same crap,secondary air blah blah...I read online somewhere that the car needs to be driven a certain way for about 300 miles or so,meaning highway and city mix...could that be the reason it's not clearing itself?
 

·
Registered
2006 Cadillac DTS
Joined
·
52 Posts
I bought a new pump and had a guy installed it....after buying another new part for it that wasn't the pump. Got the car back the other day and drove it today for the first time since then.The light stayed off for a couple days and came back on tonight.I used my remote start like 4 or 5 times today,if that has anything to do with it. I cleared the codes again!Same crap,secondary air blah blah...I read online somewhere that the car needs to be driven a certain way for about 300 miles or so,meaning highway and city mix...could that be the reason it's not clearing itself?
Just to be clear, literally you can get the secondary air system to clear in the PCM. Start the car cold, let the air pump kick on and cycle until you dont hear it, turn off car, repeat 3-4 times. Your not letting the car warm up, just letting the pump run. If the air system has a fault it will put your check engine light right back on.
My advice, if brand new pump, pull the hose from the air filter housing it goes down to the pump. then pressurize it with a shop vac or air compressor. Spray down all hoses to secondary air pump up to the secondary air check valve with soapy water, if leaks, repair as applicable if leaks. If no leaks, I would pull off the secondary air check valve, and clean every bit of carbon out I could and put back on. If no changes, then its either a faulty valve, wiring, or alternative you got a faulty pump out the box. Hope you figure it out.
 

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #13
Just to be clear, literally you can get the secondary air system to clear in the PCM. Start the car cold, let the air pump kick on and cycle until you dont hear it, turn off car, repeat 3-4 times. Your not letting the car warm up, just letting the pump run. If the air system has a fault it will put your check engine light right back on.
My advice, if brand new pump, pull the hose from the air filter housing it goes down to the pump. then pressurize it with a shop vac or air compressor. Spray down all hoses to secondary air pump up to the secondary air check valve with soapy water, if leaks, repair as applicable if leaks. If no leaks, I would pull off the secondary air check valve, and clean every bit of carbon out I could and put back on. If no changes, then its either a faulty valve, wiring, or alternative you got a faulty pump out the box. Hope you figure it out.
I've been starting it cold since I read this. I'm not sure what i'm supposed to listen for sound wise,and I have tinnitus too which doesn't help lol. I've taken it on the highway a little too since I read that also online regarding this issue. Only used remote start once too. Don't know if that has any effect but last few times I used it regularly and the light came back on post haste.
 

·
2006 DTS perf
2006 DTS Performance Lux III
Joined
·
956 Posts
I reset my transmission fluid monitor after changing the fluid and filter. I used my scan tool. You have to put 100 as the value to reset it back to 100%
 

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #16
I reset my transmission fluid monitor after changing the fluid and filter. I used my scan tool. You have to put 100 as the value to reset it back to 100%
I didn't see that option in my scanner.Maybe i will look again and see if I can find it.Maybe I need a better scanner.Thanks.
 

·
2006 DTS perf
2006 DTS Performance Lux III
Joined
·
956 Posts
I didn't see that option in my scanner.Maybe i will look again and see if I can find it.Maybe I need a better scanner.Thanks.
Mi\y scanner was $2000 it's does just about anything. Even if you goes past 100k no code is thrown or any notification. It just shows as a fault when reading the modules.
 

·
Registered
1968 Deville convertible
Joined
·
38 Posts
by a tech 2 for 150 bucks or way less. same ones dealers uses even has the same stickers. Comes with the 32MB Card TIS2000 and CANDI. It does all types of cool stuff
 

·
2008 DTS
Joined
·
94 Posts
Discussion Starter #19
by a tech 2 for 150 bucks or way less. same ones dealers uses even has the same stickers. Comes with the 32MB Card TIS2000 and CANDI. It does all types of cool stuff
Including resetting the tranny life??lol..I'm still getting a damn CEL for the secondary air
 

·
Registered
1968 Deville convertible
Joined
·
38 Posts
Can't you reset it like you do the oil? I just went to look at mine and the transformation life isn't even there. I could of swore it was. here is what a tech 2 can do. basically everything but drive the car. Its big and bulky and is oldschool but its works. I have the clone even comes with the GM stickers. IMO GM buys these than say it's theirs and charges 2k for them but I haven't researched for that to be a fact or not but that is just my opinion.

 
1 - 20 of 38 Posts
Top