Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
2008 CTS4
Joined
·
3 Posts
Discussion Starter #1
I bought a used 2008 CTS4 in Feb 2014 with 70K miles on it. In May literally 3 months after purchasing it the transmission went out on me. Thank god i bought an warranty on the vehicle to help with the cost. I took it to the Waldorf Cadillac dealership to have the work done. On my invoice they said Technician disassembled the transfer case and the transmision and replaced the input shaft and output shaft. Reassembled and test drove the vehicle. operating as designed.

Total parts came to $716 and labor was $2400. Ended up paying $660 out of pocket after what warranty paid. It is now June 13, 2015, literally 13 months from the time the issue occurred and was supposedly fixed and my transmission went out on me again last night! The same whistle noise as the first time!!! Dealership wont help because warranty on parts on labor was 12months/12000 miles.
Service technician said i could start a whole new ticket and that it would take over a week to get looked at because their transmission tech is currently backed up. I wouldn't take it back to them in the 1st place if the job they did lasted a year. Called GM Customer Service and the lady said since my car is over 100K miles that they cant help with a free diagnostic at another dealership.
she said if i have a dealership diagnose the car, and find it to be the transmission again , they could open a case for me to get help with cost but i am not guaranteed anything! I will never buy another GM car in my life! It's sad to see so many threads on websites with people dealing with the same problem and the company does nothing. $6000 of repairs for the same issue within a year????
I could have bought a more reliable Japanese used car with that money. Now I'm stuck with a piece of junk, with a loan on it!!
 

·
Registered
SOLD - 2010 CTS4 Premium Wagon-Diamond White-Cashmere Interior
Joined
·
2,930 Posts
Sorry to hear of your problems. Twice with the same failure is VERY unheard of here.

Do start a 'ticket' with Cadillac Customer Service! It is possible that the dealership installed the same old part numbers that have been failing. There is supposed to be a new set of upgraded parts being used.

Good Luck, Marv
 
1 - 2 of 2 Posts
Top