Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
NONE
Joined
·
70 Posts
Discussion Starter #1
I can hear the motor when the up or down buttons are pressed but the front of the seat does not move up or down. All the other functions work just fine including the lumbar after I replaced it a few months back. I am going to remove the seat this weekend and was just curious if anyone else has had this happen and what they found the problem and/or fix was. My guess is stripped gears or a coupler of some sort is loose but I have never worked on a seat with power tilt so I am not sure how Cadillac chose to do this.

Anyhow, if anyone has experience with this please post up. If you just took it to the dealer and had them fix it and they did not tell you what failed then no need to post up. I usually fix all my own stuff and the dealer is the absolute last resort as I hate paying someone to do something that I can do myself and I enjoy stuff like this.
 

·
Registered
2007 Cadillac Escalade ESV
Joined
·
7 Posts
I have the same issue... let me know what you find, i also hear the motor, but get no movement... the passengers side works great however...
 

·
Registered
66DeVille Vert 76Coupe Delegance 07Escalade ESV 96Fleetwood 83Coupe Deville 70Calais
Joined
·
661 Posts
Mine did this too. I looked under there and the motor was trying to turn but couldnt move the screw drive. I put a screw driver on the screw drive and hit it with a hammer in a few different spots to unjam it and kept hitting the button for up and down while doing it and it broke it free. I read it on a forum for other cadillac cars. Still works 6 months later. Could add grease to keep it from happening again i suppose. Good luck.
 
1 - 3 of 3 Posts
Top