Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2010 DTS
Joined
·
15 Posts
Discussion Starter #1
Battery is good, headlights bright was driving and shut it off. Windows won’t roll up car won’t turn over. Checked all fuses that I know of. Removed rear seat checked battery and fuses. Is there a mega fuse somewhere? Battery has 12.8 volts headlights bright ¯\(ツ)
 

·
Registered
Joined
·
3 Posts
Oh honestly I read that opposite. Sorry long day I guess. So no matter how many times you try to cycle ignition the windows won’t roll up?
 

·
Registered
DTS '06 Lux II + Sunroof
Joined
·
19 Posts
I'd have someone test the battery, see if it has enough Cold Crank Amps to start the car.
It could also be a bad starter relay.
 

·
Registered
Joined
·
3 Posts
I was gonna say try and disconnect the battery for 30 min or so and see if it resolves the problem for now. That would be the first step in the diagnosis process IMO.

Also just because batt reads 12.8 doesn’t mean it’s “good”. Visually inspect to see if any signs of swelling are present and if there are any date or number/letter code stickers on it that will determine the batteries age. Battery should be load tested. Bc when you turn the key all power is diverted to the starter. That’s why power seats, windows, radio, ect all lose power when cranking. Although I’m still a bit confused as to why windows won’t roll up if lights, ect work and no signs of low voltage during last drive cycle.. I’m not much help but curious of the resolution here.
 

·
Registered
2010 DTS
Joined
·
15 Posts
Discussion Starter #8
Just to let everyone know and to close this problem, it was the battery. replaced with new and everything works! I couldn't understand why the headlights stayed bright while trying to start it. Usually the lights should go dim an all my past experiences. Oh well glad it's running. Thanks to all that responded
 
1 - 8 of 8 Posts
Top