Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
2007 DTS
Joined
·
6 Posts
Discussion Starter #1
I have a 2007 DTS with about 140K on it. Saturday night I'm out driving with friends on a very busy street, notice the engine starts to rev really high, but minimal acceleration. Tons of white smoke coming out back. Trying to get pulled over into a parking lot (about 50 yards) and acceleration is non-existent. Revs really high, but car won't move at all. Tons of white smoke pouring out from under hood & tailpipe both - trans fluid (looked like gallons) poured out all over the roadway. We got it pushed into the parking lot with help from several other friendly motorists, and had it towed to shop by our house. While sitting waiting on tow truck, more trans fluid leaked out onto ground (not a large amount - looked like we left most in the road). Due to holiday weekend, of course it'll be Tuesday before they even look at it.

A few months ago we had an issue with some sluggish acceleration. Weather was very cold, we attributed it to that. It was suggested we check trans fluid, we did & it was low. Added some, and things were fine after that. It's been driving fine, no fluid on the ground at home or at work. Basically no other problems at all until it completely failed Saturday night.

Wondering if anyone has any thoughts on what it could be (total trans failure, etc?) and any guesses as to repair costs. We won't hear from the shop until Tuesday and of course we're thinking the worst at this point but would love to hear any thoughts or input.

----------

Sorry,c ar has about 110K on it, not 140.
 

·
Registered
2011 DTS Platinum
Joined
·
4,633 Posts
I have a 2007 DTS with about 140K on it. Saturday night I'm out driving with friends on a very busy street, notice the engine starts to rev really high, but minimal acceleration. Tons of white smoke coming out back. Trying to get pulled over into a parking lot (about 50 yards) and acceleration is non-existent. Revs really high, but car won't move at all. Tons of white smoke pouring out from under hood & tailpipe both - trans fluid (looked like gallons) poured out all over the roadway. We got it pushed into the parking lot with help from several other friendly motorists, and had it towed to shop by our house. While sitting waiting on tow truck, more trans fluid leaked out onto ground (not a large amount - looked like we left most in the road). Due to holiday weekend, of course it'll be Tuesday before they even look at it.

A few months ago we had an issue with some sluggish acceleration. Weather was very cold, we attributed it to that. It was suggested we check trans fluid, we did & it was low. Added some, and things were fine after that. It's been driving fine, no fluid on the ground at home or at work. Basically no other problems at all until it completely failed Saturday night.

Wondering if anyone has any thoughts on what it could be (total trans failure, etc?) and any guesses as to repair costs. We won't hear from the shop until Tuesday and of course we're thinking the worst at this point but would love to hear any thoughts or input.

----------

Sorry,c ar has about 110K on it, not 140.
Check the lines from the trans to the radiator.. One of them may have came loose.
 
1 - 4 of 4 Posts
Top