Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
Hey guys I just traded a 2001 Mercedes ml320 with 300000km for a 2007 CTS with 213000km.

The car has some electrical issues, traction control light, fuel gauge, temp gauge, auto shifter lights all not working. I've searched the forums, seems pretty common.

Main questions
1: The turn signals do not work. I took the flasher apart and two solder points were bad. I soldered them and now I have working drl's that I didn't realize weren't working lol. I ordered a new turn signal switch, am I on the right track?
573965


2: The headlights are aftermarket which I did not know. I can't figure out the brand or what the headlights are. Does anyone know what kind of headlights they are? Picture included.
(Edit: I figured out they are specd and use h1 bulbs)
573964



This seems like a great forum. Thanks.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Yeah, I checked all fuses in the whole car. The turn signal flasher that I took apart and repaired the solders joints is the only "relay" for the turn signals. When I turn the turn signal on it clicks shut and that's it. No lights come on.

My turn signal switch comes Friday, hopefully that fixes it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
I replaced the turn signal switch and it still doesn't work. Ordered a flasher and am going to try that. I really need to figure out the theft issue.
 
1 - 7 of 7 Posts
Top