Cadillac Owners Forum banner
1 - 4 of 4 Posts

· Registered
2007 CTS 3.6
Joined
·
1 Posts
Discussion Starter · #1 ·
HELP!! Just moved to VT few mos ago. Had oil change 3 weeks ago. Vehicle has been running great (155k miles). My roommate moved my car yesterday for the snow plow guy and said the car slid on the ice and ended up sideways in a snow bank. Had to dig it out of the snow & get the plow guy to help get it out. Went to leave for work and the check engine light is on, engine rough and clouds of smoke coming out of the dual exhaust. Took it to small town mechanic here who gave me these codes and said it's not something he can fix...need to take it to someone with "big diagnostic computer". Is it coincidence or could sliding down a bank do damage? It was fine before this. Am I screwed with these codes? Had both valve cover gaskets, spark plug tubes/seals/plugs replaced about 3 mos ago when I broke down in NJ on the way here from FL. The first mechanic took me for a ride, but the 2nd did a great job and actually fixed it!! So I'm worried about being taken for another ride. Any insight and/or advice would be greatly appreciated!!!
 

· Registered
2007 CTS 3.6 >151k miles
Joined
·
1,177 Posts
Before doing anything else, I would disconnect the neg battery cable to clear the codes, then reinstall and start the car. This way you will be able to tell whether you had an intermittent problem that caused the car to go into limp mode, or if it is something bigger that needs attention.
 

· Registered
2007 CTS 3.6 >151k miles
Joined
·
1,177 Posts
Also, how many miles since the oil change 3 weeks ago? And did you do much freeway driving during that time? These symptoms can indicate low oil. IME the oil consumption is out of control with freeway driving in these cars - about 1 qt every 800-1000 miles. Be sure to keep it full.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top