Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2007 CTS
Joined
·
27 Posts
Discussion Starter #1
About a year my passenger front speaker stopped working. I replaced it with the correct ohm aftermarket speaker by a pro audio shop and about 6 months after it stopped working again. any suggestions?
 

·
Registered
2007 CTS
Joined
·
27 Posts
Discussion Starter #2
Re: 2007 Cadillac cts passenger front speaker stoped working

anyone have the slightest idea on what it could be???
 

·
Registered
2007 CTS
Joined
·
27 Posts
Discussion Starter #4
did u take it out and inspect it? Could be just a loose wire.
I understand how it could be a loose wire but I have done custom audio installs many times. In this case do you think it could be the harness that is near the hinges of the door??

----------

Also to add to the equation my factory sub blew, do not know if that is anything as well as I have what looks like a worm trail across my display on the factory radio screen.
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,479 Posts
The factory sub is questionable at best, quite a POS actually if you ask me.

If you suspect the harness in the door I'd jump it with your own wire and see if that fixes your issue, otherwise I'd start simple like others suggested and inspect the connection point at the speaker. If that checks out remove it and make sure it works from another output source.

As far as the LED worm trail, the LED is bleeding and will only get worse with time - It'll need replacing eventually.
 
1 - 5 of 5 Posts
Top