Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I lost clock, then 2 days later everything is dead to the navi and radio, the fuse under the seat is good, i was wondering if there is a fuse behind the radio to check, i'm hoping it's not cooked because i know how easy it is to mess up everything trying to put in new system. i was wondering about resetting the computer or something, idk i'm lost
 

·
Registered
08 STS 1SG HUD ACC F55 AWD, 08 STS 1SG Platinum HUD ACC F55 RWD
Joined
·
307 Posts
Welcome to CF. Lots of helpful people here. Please add year/make/model/etc to your posts for maximum help and details are helpful and sometimes important.
How did you lose the clock and did you do anything unusual or different before losing the clock OR between losing the clock and losing the whole radio stack? Did you do anything trying to fix the clock?
 

·
Registered
Joined
·
7 Posts
I spent several hours devouring the 58 pages of a post regarding the clock/navigation systems in our cars. Seems there is now an update to the firmware that can restore the clock BUT it has only been released for 2008 and newer. I quickly scanned a few comments how the update was partially successful for 2007 and older systems. You might want to go check out that thread.

 

·
Registered
06 STS-V & 06 STS 4 (sold 2016)
Joined
·
2,713 Posts
Try disconnecting the battery again and touch the disconnected cable terminals together for a short time. Then reconnect the battery.


That does a full reset of all the systems in the car. Your Nav unit will do a full reboot if it's not defective.
 

·
Registered
09 cadillac cts4 09 yukon Denali
Joined
·
194 Posts
Bad battery makes electronic act crazy.
I have had screen on dvd player go blank after jump starting our 09 yukon. I fixed it by disconnecting the positive side of battery for 5 minutes
 
1 - 6 of 6 Posts
Top