Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,341 Posts
Discussion Starter #1
so the right clip holding the sunroof wind deflector broke! looking at GMpartsdirect i have to buy the whole housing to replace that part?

please tell me theres another way to fix this?
 

Attachments

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,341 Posts
Discussion Starter #3
haha i was thinking welding it back but ill call around and see what i can find. im a heavy user of the sunroof
 

·
Registered
08 STS4 V8 1SG & 04 SRX4 V8 & 01 Monte SS
Joined
·
4,988 Posts
You could also just remove the wind deflector ... its quieter when you hold it down anyways, so if you just remove it then you will have a quieter ride with it open.
 

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,341 Posts
Discussion Starter #5
You could also just remove the wind deflector ... its quieter when you hold it down anyways, so if you just remove it then you will have a quieter ride with it open.
never thought about that, ill break off the other end tomorrow and see how it sound. found a used one off of rockauto.
 

·
Registered
2005 STS V8
Joined
·
165 Posts
I had the same thing happen -- removed the deflector, not missing it. it unhooks no need to break it off
 

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,341 Posts
Discussion Starter #8
I had the same thing happen -- removed the deflector, not missing it. it unhooks no need to break it off
Yea that's what I did. Squeeze it together and it pops out. It sounds weird when going above 70 without the deflectors tho
 
1 - 8 of 8 Posts
Top